Bug 5548 - segfaults including %m conf from an included file from smb.conf
segfaults including %m conf from an included file from smb.conf
Status: VERIFIED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Client tools
unspecified
x86 Linux
: P3 major
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-17 13:13 UTC by Marcelo
Modified: 2008-06-20 09:27 UTC (History)
1 user (show)

See Also:


Attachments
Patch fixing the segfaults (1.09 KB, patch)
2008-06-18 15:33 UTC, Michael Adam
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcelo 2008-06-17 13:13:01 UTC
Im running samba-3.2.0-1.rc1.15.fc9.i386. If I "include = /etc/samba/smb-server.conf" from smb.conf and I "include = /etc/samba/smb.conf.%m" from smb-server.conf, smbclient and nmblookup segfaults on command line. If I take the second include to smb.conf, both cli commands run ok, but testparm keeps segfaulting.

This combination of includes were running ok in samba 3.0.
Comment 1 Michael Adam 2008-06-18 03:56:42 UTC
I am looking into this.
Comment 2 Michael Adam 2008-06-18 15:33:51 UTC
Created attachment 3349 [details]
Patch fixing the segfaults

I fixed this in v3-3-test and v3-2-test.
Will go into 3.2.0 final.

Attached find the patch you can use with v3-2-stable or the rc tarball.
Please test.

Michael
Comment 3 Michael Adam 2008-06-18 15:35:34 UTC
Marking this as fixed.

Marcelo: Please reopen if you still have issues with the patch 
or branches v3-2-test v3-3-test.

Thanks - Michael
Comment 4 Michael Adam 2008-06-19 03:20:17 UTC
Remark: This has now gone into v3-2-stable.
Comment 5 Marcelo 2008-06-20 09:27:21 UTC
The problem is solved. Thanks