Bug 5544 - file service problem for wrapped tcl scripts
file service problem for wrapped tcl scripts
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.30
Other HP-UX
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-16 05:45 UTC by Ralf Weinert
Modified: 2010-02-22 08:19 UTC (History)
1 user (show)

See Also:


Attachments
tcl-scripts crashing (167.66 KB, application/x-gzip)
2008-07-24 01:19 UTC, Ralf Weinert
no flags Details
tcl-scripts crashes (29.73 KB, application/x-gzip)
2008-07-24 01:20 UTC, Ralf Weinert
no flags Details
tcl-script crashes (876 bytes, text/plain)
2008-07-28 00:54 UTC, Ralf Weinert
no flags Details
tcl-script crashes (534.59 KB, application/x-gzip)
2008-07-29 01:00 UTC, Ralf Weinert
no flags Details
tcl-script crashes (539.40 KB, application/x-gzip)
2008-07-29 01:01 UTC, Ralf Weinert
no flags Details
tcl-script crashes (903.71 KB, image/bmp)
2008-07-29 01:16 UTC, Ralf Weinert
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Weinert 2008-06-16 05:45:16 UTC
1) wrapped tcl-scripts are crashing when they are distributed by Samba file service. This already happens since samba version 3.0.26a. On Sparc station running Solaris operating system everything works fine. problems for example exist on a HP workstation 9000/785/c3600 (HP-UX  B11.11). 
Tcl-Scripts are wrapped with the John Ousterhood's wrapper tool for Tcl/tk 8.3.2 (prowrap) 
The samba sources are compiled and linked with the Makefile generated by 
configure --prefix=/usr/local/samba-3.0.30 --with-aio-support.

2) Another problem is distributing pcf fonts when tey are needed by the XVision tool . When XVision is started you always get the message that the fonts directory can't be accessed. These problems also happen with samba server running on the HP workstation, SParc station do not have problems.
Comment 1 Ralf Weinert 2008-06-16 08:51:22 UTC
Another problem is file modifikation time and/or file creation time are no longer shown on a client when you modify or create any files over samba.
Comment 2 Ralf Weinert 2008-07-24 01:19:43 UTC
Created attachment 3421 [details]
tcl-scripts crashing
Comment 3 Ralf Weinert 2008-07-24 01:20:14 UTC
Created attachment 3422 [details]
tcl-scripts crashes
Comment 4 Volker Lendecke 2008-07-25 03:14:36 UTC
The problem seems to be that user WW009\bw1wenr0 tries to access share V2SHARES. This is tried many dozens of times, and Samba according to its valid users setting  denies the access. Can you try to fix that and re-run the script?

Thanks,

Volker
Comment 5 Ralf Weinert 2008-07-28 00:52:42 UTC
Hi,

This problem doesn' t seem to be a problem of the tcl-script. As you can see
the logfile (smbd-good) shows no such problems. In both logfiles (smbd-good, smbd-fail) the client tries to get the same (wrapped) tcl-script, so I don't know how to solve the problem you mentioned. You can see what the tcl script is doing, I attache it to this mail
Comment 6 Ralf Weinert 2008-07-28 00:54:28 UTC
Created attachment 3424 [details]
tcl-script crashes
Comment 7 Volker Lendecke 2008-07-28 01:05:54 UTC
When looking at log.smbd-good I can not see any download of the script at all. Also this is not a full log, for example there is no negprot and session setup calls, so it is a bit difficult to compare.

Did you try to open v2shares to user WW009\bw1wenr0 to just see what happens?

Volker
Comment 8 Ralf Weinert 2008-07-28 01:33:53 UTC
Hi again,

the user WW009\bw1wenr0 it's me. as long as I try to download ascii files from that share there is no problem at all. the problems occur when downloading binaries or for example wrapped  tcl-scripts, because the tclpro compiler (as a part of the wrapper) produces byte code. Tomorrow I try to generate a new logfile, that contains evrything.  
Comment 9 Ralf Weinert 2008-07-29 01:00:22 UTC
Created attachment 3433 [details]
tcl-script crashes
Comment 10 Ralf Weinert 2008-07-29 01:01:51 UTC
Created attachment 3434 [details]
tcl-script crashes
Comment 11 Ralf Weinert 2008-07-29 01:16:40 UTC
Created attachment 3435 [details]
tcl-script crashes
Comment 12 Ralf Weinert 2008-07-29 01:18:29 UTC
Hi Volker,

I attached again two logfiles and I hope they have all the informations you need. At last there is bmp file that shows the script working well and the other one when it crashes.
Comment 13 Volker Lendecke 2008-07-29 02:44:04 UTC
Yes, thanks. Very likely the problem is buried somewhere in those logfiles. For example in the log-good there is no reference at all to init.tcl, in log-bad the interpreter tries to look for init.tcl which is not there. No idea why, I would probably have to install tcl on one of my boxes to reproduce this. Right now I've got other customers though, so this might take a while.

Sorry,

Volker
Comment 14 Ralf Weinert 2008-07-29 03:54:29 UTC
Hi Volker,

if you want to install Tcl/tk please take the TclPro 1.4.1 for windows. This is the tool you can wrap tcl-scripts with. the download page is //www.tcl.tk/software/tclpro/eval/1.4.html. there you also get the free Tclpro license key.
Comment 15 Ralf Weinert 2008-09-11 06:55:10 UTC
Hi,

as you said you need to install tcl on one of your boxes I tried to find the latest version of samba that serves properly tcl files and pcf fonts. So Samba 3.0.25b there are no problems whereas since Samba 3.0.25c and all later versions have this problem. Maybe you find a solution in the differences between the sources of samba 3.0.25b and samba 3.0.25c.     
Comment 16 Ralf Weinert 2010-02-22 08:19:21 UTC
All my HP Workstation are gone. So there is no problem left.