Bug 5537 - Compiling error about libcap on Fedora 9
Compiling error about libcap on Fedora 9
Status: RESOLVED DUPLICATE of bug 5285
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.30
x86 Linux
: P3 normal
: none
Assigned To: Tim Potter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 13:54 UTC by Ricardo Santos
Modified: 2008-06-11 15:57 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardo Santos 2008-06-11 13:54:59 UTC
I'm trying compile samba-3.0.30 on Fedora 9

It seems to be like Bug# 5285

Using FLAGS      =  -O -D_SAMBA_BUILD_=3  -I/install/samba-3.0.30/source/iniparser/src -Iinclude -I./include  -I. -I. -I./lib/replace -I./lib/talloc -I./tdb/include -I./libaddns -I./librpc -DHAVE_CONFIG_H  -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE    -I/install/samba-3.0.30/source/lib -D_SAMBA_BUILD_=3
      PICFLAG    = -fPIC
      LIBS       = -lcrypt -lcap -lresolv -lresolv -lnsl -ldl
      LDFLAGS    = -pie
      DYNEXP     = -Wl,--export-dynamic
      LDSHFLAGS  = -shared -Wl,-Bsymbolic
      SHLIBEXT   = so
      SONAMEFLAG = -Wl,-soname=
Compiling smbd/oplock_linux.c
smbd/oplock_linux.c:37: error: conflicting types for capget
/usr/include/sys/capability.h:111: error: previous declaration of capget was here
smbd/oplock_linux.c:39: error: conflicting types for capset
/usr/include/sys/capability.h:110: error: previous declaration of capset was here
The following command failed:
gcc -I. -I/install/samba-3.0.30/source  -O -D_SAMBA_BUILD_=3  -I/install/samba-3.0.30/source/iniparser/src -Iinclude -I./include  -I. -I. -I./lib/replace -I./lib/talloc -I./tdb/include -I./libaddns -I./librpc -DHAVE_CONFIG_H  -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE    -I/install/samba-3.0.30/source/lib -D_SAMBA_BUILD_=3 -fPIC -c smbd/oplock_linux.c -o smbd/oplock_linux.o
make: *** [smbd/oplock_linux.o] Error 1
Comment 1 Ricardo Santos 2008-06-11 14:44:21 UTC
Additional Info:

Fedora 9 uses libcap-2.0.6
Fedora 8 uses libcap-1.10

Seems to be an incompatibility with libcap-2.x
Comment 2 Guenther Deschner 2008-06-11 15:57:21 UTC

*** This bug has been marked as a duplicate of 5285 ***