Bug 5534 - CIFS Lists Root Mount Directory For All Subdirectories
CIFS Lists Root Mount Directory For All Subdirectories
Status: RESOLVED DUPLICATE of bug 4066
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x86 Linux
: P3 regression
: ---
Assigned To: Steve French
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-10 17:17 UTC by Jeremy Brown
Modified: 2009-05-13 16:27 UTC (History)
2 users (show)

See Also:


Attachments
test program that renames open files (847 bytes, text/plain)
2008-08-30 05:48 UTC, Jeff Layton
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Brown 2008-06-10 17:17:41 UTC
Hello,

I tried my best to search Google and the bug list for an error similar to this but I couldn't find anything with a resolution.  Sorry if this is a dupe.

I'm attempting to mount a DFS file share hosted on a Windows 2003 R2 server using the cifs module on a CentOS machine.  I have updated the kernel and samba packages to the newest available in the yum repository:

kernel-2.6.9-67.0.15.EL
samba-common-3.0.25b-1.el4_6.5
samba-client-3.0.25b-1.el4_6.5
samba-3.0.25b-1.el4_6.5

The command I'm using to mount:

mount -t cifs -o username=tempuser,password=temppass //01-fileserver/Source /mnt/source

The mount command succeeds.  However, every directory in the root of /mnt/source also lists the root of the mount.  Example, if I cd into /mnt/source/test and ls, it lists /mnt/source.  Even so, I tried writing a file to any directory and that doesn't work as well.

If more information is needed that I didn't think to provide, please let me know.  If this is a known bug then I apologize for reporting it again but I'd like to know so I know I'm not crazy.

Thanks for the help.
Comment 1 Jeff Layton 2008-08-26 12:33:46 UTC
Is this still an issue in 4.7 ?
Comment 2 Jeremy Brown 2008-08-26 12:43:00 UTC
I'm sorry, 4.7?

CentOS' newest seems to be 4.6.  Samba is 3.x and linux-cifs is 1.x from the best I can tell.

Regardless, I will try to test again with the newest repository update ASAP and give and update.

Thanks.
Comment 3 Jeff Layton 2008-08-30 05:48:00 UTC
Created attachment 3515 [details]
test program that renames open files

Test program by Wilhelm Meier.
Comment 4 Jeff Layton 2008-08-30 05:50:42 UTC
Sorry, wrong bz...
Comment 5 Shirish S. Pargaonkar 2009-03-05 21:16:11 UTC
Is this still an issue? Any updates as per comment #2?
Comment 6 Steve French 2009-05-13 16:27:14 UTC

*** This bug has been marked as a duplicate of bug 4066 ***