Bug 5509 - Mention OS X "Ignore permissions" in --link-dest docs
Mention OS X "Ignore permissions" in --link-dest docs
Status: RESOLVED FIXED
Product: rsync
Classification: Unclassified
Component: core
3.0.4
All Mac OS X
: P3 enhancement
: ---
Assigned To: Wayne Davison
Rsync QA Contact
http://lists.samba.org/archive/rsync/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-01 04:58 UTC by iwilcox
Modified: 2008-07-28 20:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iwilcox 2008-06-01 04:58:57 UTC
Hi,

I got bitten by this:
  http://lists.samba.org/archive/rsync/2005-August/013394.html
Now, obviously that's just my bad luck.  Spent a while fruitlessly Googling - it's easy to find a couple of pages on this, but only after you know what the problem is; the symptoms alone make for less specific search terms.  Then spent another while building various extra debug lines into the source to finally work out what was going on.  I suspect a percentage of rsync users might get bitten too and would have no idea how to debug it (or would know how but wouldn't try).

How about a sentence something like this within the docs for -g and/or -o?

  Note: on Mac OS X removable volumes the option "Ignore permissions on this
  volume" can interfere with uid/gid comparisons, potentially causing false
  mismatches.

Cheers,

Zak
Comment 1 iwilcox 2008-06-01 05:00:21 UTC
>   Note: on Mac OS X removable volumes the option "Ignore permissions on this
>   volume" can interfere with uid/gid comparisons, potentially causing false

Whoops, that should be "Ignore ownership on this volume".
Comment 2 Wayne Davison 2008-07-28 20:27:01 UTC
Added a mention to the manpage for 3.0.4.