Bug 5504 - winbind children dying delete the winbindd socket.
winbind children dying delete the winbindd socket.
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Winbind
unspecified
Other Linux
: P3 regression
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-30 19:10 UTC by Jeremy Allison
Modified: 2008-11-18 12:09 UTC (History)
2 users (show)

See Also:


Attachments
Patch for 3.0.x (1.74 KB, patch)
2008-05-30 19:19 UTC, Jeremy Allison
no flags Details
Patch for 3.2 (1.74 KB, patch)
2008-05-30 19:46 UTC, Jeremy Allison
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Allison 2008-05-30 19:10:33 UTC
When winbindd children are killed by the parent with a SIGTERM, they call the parent's sigterm processing function, which causes them to delete the winbindd pipe in /tmp/.winbindd/.
Even though the parent is still alive no more connections can be made.
This is a showstopper (it also exists in 3.0.x).

How has this not been seen in the field yet ?

Jeremy.
Comment 1 Jeremy Allison 2008-05-30 19:19:22 UTC
Created attachment 3322 [details]
Patch for 3.0.x
Comment 2 Jeremy Allison 2008-05-30 19:46:11 UTC
Created attachment 3323 [details]
Patch for 3.2
Comment 3 Jeremy Allison 2008-05-30 19:54:58 UTC
Fixed in 3.2, 3.0, 3.3 trees. Karolin this must be pulled into 3.2-stable.
Thanks,
Jeremy.
Comment 4 Jeremy Allison 2008-06-20 12:36:34 UTC
*** Bug 5553 has been marked as a duplicate of this bug. ***