Bug 5461 - Citrix PM fails to display groups in large domains
Citrix PM fails to display groups in large domains
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.28a
All Linux
: P3 normal
: none
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-13 08:20 UTC by Jim McDonough
Modified: 2008-05-16 11:55 UTC (History)
0 users

See Also:


Attachments
Implement _samr_GetDisplayEnumerationIndex (5.89 KB, patch)
2008-05-14 17:00 UTC, Guenther Deschner
no flags Details
samr getdispinfoindex patch against 3.0.x (8.02 KB, patch)
2008-05-16 05:51 UTC, Guenther Deschner
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim McDonough 2008-05-13 08:20:25 UTC
Due to lack of GetDisplayEnumerationIndex implementation, Citrix Presentation Manager fails to display groups to assign to applications when the number of groups is large.
Comment 1 Guenther Deschner 2008-05-14 17:00:34 UTC
Created attachment 3292 [details]
Implement _samr_GetDisplayEnumerationIndex

This patch (against 3-3-test/3-2-test) should fix it.
Comment 2 Guenther Deschner 2008-05-16 05:51:49 UTC
Created attachment 3294 [details]
samr getdispinfoindex patch against 3.0.x

This patch has proven to fix the problem for a large customer site.
Comment 3 Guenther Deschner 2008-05-16 08:37:38 UTC
As that patch has been sucessfully in production for over a year already, I pushed those to 3-3 and 3-0.
Comment 4 Jeremy Allison 2008-05-16 11:55:46 UTC
If it's already been in production for a year, and will be in 3.0.x, then we should also have it in 3.2 stable, as otherwise 3.2 will be a regression against 3.0.x.
Jeremy.