Bug 5447 - (samba 3.0) NFSv4/ZFS ACLs dont work on NFS mount because POSIX ACL are being used
(samba 3.0) NFSv4/ZFS ACLs dont work on NFS mount because POSIX ACL are being...
Status: RESOLVED DUPLICATE of bug 5446
Product: Samba 3.0
Classification: Unclassified
Component: VFS
3.0.28a
All Solaris
: P3 normal
: none
Assigned To: Michael Adam
Samba QA Contact
http://bugs.opensolaris.org/view_bug....
:
Depends on: 5446
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-07 02:49 UTC by Nils Goroll
Modified: 2008-11-16 17:58 UTC (History)
3 users (show)

See Also:


Attachments
Proposed workaround (fix?) (1.05 KB, patch)
2008-05-07 02:51 UTC, Nils Goroll
no flags Details
Cleaned up patch for vfs_zfsacl.c (4.08 KB, patch)
2008-06-16 12:51 UTC, Nils Goroll
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nils Goroll 2008-05-07 02:49:19 UTC
pro-forma bug for Samba3.0
see bug#5446 for 3.2 and general discussion

I will attach a 3.0 specific proposed patch here.

Side note: as far as I understand samba VFS, the VFS OPs
for this workaround should be set to SMB_VFS_LAYER_OPAQUE,
but this leads to SIGSEGVs, which is why I used
SMB_VFS_LAYER_TRANSPARENT for this patch.

Any improvements welcome.
Comment 1 Nils Goroll 2008-05-07 02:51:17 UTC
Created attachment 3279 [details]
Proposed workaround (fix?)
Comment 2 Nils Goroll 2008-06-16 12:49:16 UTC
see bug#5446 for some notes on why I belive the patch is a valid solution
Comment 3 Nils Goroll 2008-06-16 12:51:35 UTC
Created attachment 3345 [details]
Cleaned up patch for vfs_zfsacl.c

Have cleaned up function signatures and successfully repeated validation tests
Comment 4 Michael Adam 2008-11-16 17:58:44 UTC
Marking this bug as duplicate of 5446 since the zfsacl module is not available in samba 3.0

*** This bug has been marked as a duplicate of 5446 ***