Bug 5423 - 2 or more "valid users" lines.
2 or more "valid users" lines.
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.28
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-27 14:18 UTC by Magnus
Modified: 2008-04-30 07:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus 2008-04-27 14:18:04 UTC
When using several "valid users =" , "write list=" options only the last occurance is validated.

In this example share only user24 can login:
----------------------------
[shared]
path = /var/samba/shared
comment = Samba Share
valid users = user1 user23 user39 user4 user52 user67 user48 user42 user62
valid users = user24 (ONLY THIS ROW IS VALIDATED)
read only = no
available = yes
browseable = yes
writable = no
guest ok = no
public = no
printable = no
share modes = no
locking = no
----------------------------

Tested using SAMBA-3.0.28-0.fc7 on Fedora 7.
Also reported by people using "Ubuntu/7.10 (gutsy)" and gsambad / gadmin-samba guis.

I hope this can be fixed.

Sincerely,
Magnus
Comment 1 Gerald (Jerry) Carter 2008-04-27 15:01:46 UTC
This is by design.  Please use the '\' character to continue long lines 
in the smb.conf.
Comment 2 Magnus 2008-04-27 16:22:00 UTC
(In reply to comment #1)
> This is by design.  Please use the '\' character to continue long lines 
> in the smb.conf.
> 

Seems ok, thanks!
Comment 3 Magnus 2008-04-30 07:10:09 UTC
Additional info: fixed in gadmin-samba-0.2.5