Bug 5406 - alignment bug in reset on zero vc path
alignment bug in reset on zero vc path
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.28a
All All
: P3 major
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 06:43 UTC by Björn Jacke
Modified: 2012-09-12 22:30 UTC (History)
0 users

See Also:


Attachments
proposed fix (1.41 KB, patch)
2008-04-21 06:44 UTC, Björn Jacke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Björn Jacke 2008-04-21 06:43:19 UTC
on a gcc compiled 3.0.25a on Solaris/Sparc I saw bus errors caused by an alignment bug in sesssetup.c when reset on zero vc is activatred. Attached is the patch to fix that, the patch is from Volker.

Jerry - I think this should go into 3.0.28b.
Comment 1 Björn Jacke 2008-04-21 06:44:14 UTC
Created attachment 3266 [details]
proposed fix
Comment 2 Volker Lendecke 2008-04-21 08:46:10 UTC
Pushed to 3-0, thanks! 3.2 looks quite differently here, can you see if 3.2 has the same problem?

Thanks,

Volker
Comment 3 Björn Jacke 2012-09-12 22:30:13 UTC
i think this works in recent releases on big endian machines