Bug 5405 - build error with --enable-static=yes and --enable-shared=no
build error with --enable-static=yes and --enable-shared=no
Status: RESOLVED WORKSFORME
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
3.2.0
x86 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-20 06:20 UTC by stranger
Modified: 2008-09-05 03:12 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stranger 2008-04-20 06:20:56 UTC
my environment is :fedora core 8 with linux kernel 2.6.23 ,gcc 4.1.2 and running on VMwareR Workstation 6.0.2build-59824 
when I build the samba3.2.0pre2 with "./configure --enable-static=yes --enable-shard=no", I gain some error like this :

Compiling smbd/server.c
Linking bin/smbd
modules/vfs_audit.o: In function `init_module':
vfs_audit.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_extd_audit.o: In function `init_module':
vfs_extd_audit.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_full_audit.o: In function `init_module':
vfs_full_audit.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_netatalk.o: In function `init_module':
vfs_netatalk.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_fake_perms.o: In function `init_module':
vfs_fake_perms.c:(.text+0xe8): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_default_quota.o: In function `init_module':
vfs_default_quota.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_readonly.o: In function `init_module':
vfs_readonly.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_cap.o: In function `init_module':
vfs_cap.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_expand_msdfs.o: In function `init_module':
vfs_expand_msdfs.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_shadow_copy.o: In function `init_module':
vfs_shadow_copy.c:(.text+0x52): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_shadow_copy2.o: In function `init_module':
vfs_shadow_copy2.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_xattr_tdb.o: In function `init_module':
vfs_xattr_tdb.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_streams_xattr.o: In function `init_module':
vfs_streams_xattr.c:(.text+0x1c): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_readahead.o: In function `init_module':
vfs_readahead.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_fileid.o: In function `init_module':
vfs_fileid.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/vfs_syncops.o: In function `init_module':
vfs_syncops.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/CP850.o: In function `init_module':
CP850.c:(.text+0x1a6): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
modules/CP437.o: In function `init_module':
CP437.c:(.text+0x1a6): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
auth/auth_script.o: In function `init_module':
auth_script.c:(.text+0x0): multiple definition of `init_module'
modules/vfs_recycle.o:vfs_recycle.c:(.text+0x7a): first defined here
smbd/vfs.o: In function `vfs_init_custom':
vfs.c:(.text+0x1fe5): undefined reference to `vfs_recycle_init'
vfs.c:(.text+0x1ff3): undefined reference to `vfs_audit_init'
vfs.c:(.text+0x2001): undefined reference to `vfs_extd_audit_init'
vfs.c:(.text+0x200f): undefined reference to `vfs_full_audit_init'
vfs.c:(.text+0x201d): undefined reference to `vfs_netatalk_init'
vfs.c:(.text+0x202b): undefined reference to `vfs_fake_perms_init'
vfs.c:(.text+0x2039): undefined reference to `vfs_default_quota_init'
vfs.c:(.text+0x2047): undefined reference to `vfs_readonly_init'
vfs.c:(.text+0x2055): undefined reference to `vfs_cap_init'
vfs.c:(.text+0x2063): undefined reference to `vfs_expand_msdfs_init'
vfs.c:(.text+0x2071): undefined reference to `vfs_shadow_copy_init'
vfs.c:(.text+0x207f): undefined reference to `vfs_shadow_copy2_init'
vfs.c:(.text+0x208d): undefined reference to `vfs_xattr_tdb_init'
vfs.c:(.text+0x20a9): undefined reference to `vfs_streams_xattr_init'
vfs.c:(.text+0x20b7): undefined reference to `vfs_readahead_init'
vfs.c:(.text+0x20c5): undefined reference to `vfs_fileid_init'
vfs.c:(.text+0x20d3): undefined reference to `vfs_syncops_init'
lib/iconv.o: In function `smb_iconv_open':
iconv.c:(.text+0xc02): undefined reference to `charset_CP850_init'
iconv.c:(.text+0xc10): undefined reference to `charset_CP437_init'
auth/auth.o: In function `load_auth_module':
auth.c:(.text+0x1097): undefined reference to `auth_script_init'
collect2: ld returned 1 exit status
make: *** [bin/smbd] Error 1

anyone knows where the problem is or any suggestion ?
Comment 1 Volker Lendecke 2008-05-13 05:37:17 UTC
I can not reproduce that error here. Did you do a "make clean" between two compiles that have different configure options?

Volker
Comment 2 Karolin Seeger 2008-09-05 03:12:49 UTC
Reporter is not responding.
Closing out bug report.
Please re-open if it is still an issue for you.