Bug 5376 - Broken "Guest LogIn" with Version 3.2.0pre2
Broken "Guest LogIn" with Version 3.2.0pre2
Status: RESOLVED DUPLICATE of bug 5375
Product: Samba 3.2
Classification: Unclassified
Component: Config Files
x64 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-04-07 18:34 UTC by Daniel Leewen
Modified: 2008-04-08 00:45 UTC (History)
1 user (show)

See Also:

Screenshot : Samba keeps asking for a Password for the "Guest" account (14.65 KB, image/png)
2008-04-07 18:39 UTC, Daniel Leewen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Leewen 2008-04-07 18:34:50 UTC
I have "dist-upgraded" my Debian (unstable/Sid) Machine and installed Samba 3.2.0 pre2.
My "old" Samba-Installation was working fine, but the new Version is not able to Handle "Guest" Accounts properly.
Every time when i try to access the Samba-Share, Windows (WinXP Pro. (32 Bit), SP2) keeps asking for a Password.

I do not think this is a config/Firewall issue, because my "smb.conf" was working fine with the "old" Version.

It seems, like no share is available anymore, "smbclient -L localhost -U%" outputs :
============[ testparm output ]===================
Domain=[EXIL] OS=[Unix] Server=[Samba 3.2.0pre2]
Receiving SMB: Server stopped responding
tree connect failed: Call timed out: server did not respond after 20000 milliseconds

"testparm" outputs is :
============[ testparm output ]===================
Load smb config files from /etc/samba/smb.conf
Processing section "[printers]"
Processing section "[print$]"
Processing section "[data]"
Loaded services file OK.
Press enter to see a dump of your service definitions

        workgroup = EXIL
        server string = %h server
        interfaces =, localhost
        bind interfaces only = Yes
        security = SHARE
        obey pam restrictions = Yes
        passdb backend = tdbsam
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        unix password sync = Yes
        log level = 2
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        panic action = /usr/share/samba/panic-action %d
        invalid users = root
        hosts allow = 192.168.2., localhost
        comment = Exchange
        path = /home/share/files
        force user = share
        force group = EXIL
        read only = No
        create mask = 0777
        guest ok = Yes
        volume = 160GB Data-Disk
============[ testparm output ]===================

Daniel Leewen
Comment 1 Daniel Leewen 2008-04-07 18:39:31 UTC
Created attachment 3250 [details]
Screenshot : Samba keeps asking for a Password for the "Guest" account
Comment 2 Volker Lendecke 2008-04-08 00:44:38 UTC
Please look at the patch in bug 5375, this looks very similar: https://bugzilla.samba.org/attachment.cgi?id=3246&action=view

Comment 3 Volker Lendecke 2008-04-08 00:45:29 UTC

*** This bug has been marked as a duplicate of 5375 ***