Bug 5360 - -o pass="password of length > 17" fails with password too long
-o pass="password of length > 17" fails with password too long
Status: RESOLVED DUPLICATE of bug 4300
Product: CifsVFS
Classification: Unclassified
Component: user space tools
2.6
x86 Linux
: P3 trivial
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 08:16 UTC by Jérôme Poulin
Modified: 2009-05-14 15:14 UTC (History)
1 user (show)

See Also:


Attachments
I used those modifications (7.26 KB, patch)
2008-03-31 08:17 UTC, Jérôme Poulin
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jérôme Poulin 2008-03-31 08:16:55 UTC
After checking the source file, I just removed the check for password length and it seems to work correctly. Tested on Windows 2003 Server with password: "This is a long admin Password!"
Comment 1 Jérôme Poulin 2008-03-31 08:17:37 UTC
Created attachment 3227 [details]
I used those modifications
Comment 2 Andreas Schneider 2008-03-31 11:11:15 UTC
The value should just be increased from 17 to 128.

LM passwords are limited to 14 characters, NTLM passwords are limited to 128
characters.

There was already a discussion at the cifs mailing list about this topic.
Comment 3 Ajos1 2008-08-29 17:52:17 UTC
Has this been fixed?  I am getting "password too long" for length 17 and above...

I am:

===================================
[root@tbshspx1 ~]# uname -r
2.6.25.14-108.fc9.i686

===================================
[root@tbshspx1 ~]# smbclient -V
Version 3.2.0-17.fc9

===================================
[root@tbshspx1 ~]# mount -V
mount (util-linux-ng 2.13.1)

===================================
[root@tbshspx1 ~]# mount.cifs -V
** NOTHING BUT HELP *** ... BUT THE MAN PAGE RECKONS Samba 3.2

===================================
17 Character Password... FAILS...

[root@tbshspx1 ~]# mount.cifs -o username="auser",password="12345678901234567" "//server/share" "/mnt/target"

password too long

===================================
16 Character Password... WORKS...

[root@tbshspx1 ~]# mount.cifs -o username="auser",password="1234567890123456" "//server/share" "/mnt/target"

Mounting the DFS root for domain not implemented yet
No ip address specified and hostname not found

It tries... though the username and password are made up for the test...

===================================

Many thanks... Ajos1
Comment 4 Steve French 2009-05-14 15:14:22 UTC
Made a consistent password limit of 127 (matching Windows maximum) and checked into mount.cifs.c in Samba master

*** This bug has been marked as a duplicate of bug 4300 ***