Bug 5328 - ./net rpc join failed to join 2008 server
./net rpc join failed to join 2008 server
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.28
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-17 03:49 UTC by Feroz Ahmed
Modified: 2008-04-10 06:10 UTC (History)
0 users

See Also:


Attachments
smb.conf file (3.27 KB, text/plain)
2008-03-17 03:50 UTC, Feroz Ahmed
no flags Details
logs (16.39 KB, text/plain)
2008-03-17 03:50 UTC, Feroz Ahmed
no flags Details
Logs (214.38 KB, text/plain)
2008-03-19 03:38 UTC, Feroz Ahmed
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Feroz Ahmed 2008-03-17 03:49:28 UTC
Im using samba-3.0.28a.

When i run "net rpc join" for 2008 server, im getting the following error.

"Unable to find a suitable server"

But I am able to join 2003 server with out any problem.

Log file and smb.conf files are attached.

Can any one help me out in this regard??
Comment 1 Feroz Ahmed 2008-03-17 03:50:18 UTC
Created attachment 3177 [details]
smb.conf file
Comment 2 Feroz Ahmed 2008-03-17 03:50:43 UTC
Created attachment 3178 [details]
logs
Comment 3 Guenther Deschner 2008-03-19 02:12:46 UTC
Cannot reproduce that (tested with most recent 3.0 and 3.2 code).

If you just use the -S YOURDCNAME switch, does it find and join the domain then?
Comment 4 Feroz Ahmed 2008-03-19 03:38:17 UTC
Created attachment 3192 [details]
Logs

Even with -S option im unable to join Domain.

Im getting this error

  cli_rpc_pipe_open: cli_nt_create failed on pipe \lsarpc to machine nam6.jp.  Error was NT_STATUS_ACCESS_DENIED


Refer the attachment
Comment 5 Feroz Ahmed 2008-03-21 03:14:36 UTC
>>>>Cannot reproduce that (tested with most recent 3.0 and 3.2 code).

Do you mean this is a known bug with 3.0.28a and is fixed in the resent 3.0/
3.2 code?
Comment 6 Guenther Deschner 2008-04-10 06:10:14 UTC
This is fixed in 3-0-test and 3-2-test, please reopen if still a failure there.