Bug 5313 - Tools fail to find libtalloc.so
Tools fail to find libtalloc.so
Status: RESOLVED INVALID
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
3.2.0
x86 Linux
: P3 regression
: ---
Assigned To: Michael Adam
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 23:50 UTC by Feroz Ahmed
Modified: 2008-03-18 03:42 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Feroz Ahmed 2008-03-06 23:50:55 UTC
Dear Samba Team,
When i run "net ads" command im getting the following error... 


[root@feroz123 bin]# ./net ads join -U administrator
./net: error while loading shared libraries: libtalloc.so.1: cannot open shared object file: No such file or directory
[root@feroz123 bin]#
[root@feroz123 bin]#
[root@feroz123 bin]#
[root@feroz123 bin]#
[root@feroz123 bin]# cd ../sbin/
[root@feroz123 sbin]# ./nmbd -D
./nmbd: error while loading shared libraries: libtalloc.so.1: cannot open shared object file: No such file or directory
[root@feroz123 sbin]# ./smbd -D
./smbd: error while loading shared libraries: libtalloc.so.1: cannot open shared object file: No such file or directory
[root@feroz123 sbin]#
[root@feroz123 sbin]#
[root@feroz123 sbin]#
[root@feroz123 sbin]#
Comment 1 Michael Adam 2008-03-07 07:11:32 UTC
Yes, Samba 3.2.0 now uses shared libraries internally by default.
Your dynamic loader must know how to find the libs.

You can do several things to accomplish this:

-1) disable using shared libs internally by using the configure
    option "--disable-shared-libs".
    This *won't* disable use of libwbclient.so, though!
 0) install in such a way that the libs get placed in a directory
    that is already searched for libs (e.g. /usr/lib/)
 1) "export LD_LIBRARY_PATH=/your/samba/library/path" (example for bash)
 2) add a line with the folder containing your samba libs to /etc/ld.so.conf
    (or a dedicated file /etc/ld.so.conf.d/samba_foo.conf which has to be
     included in /etc/ld.so.conf)
 3) build your binaries with an rpath: 
    LDFLAGS="-Wl,-R,/your/samba/library/path" ./configure ...

Cheers, Michael
Comment 2 Michael Adam 2008-03-18 03:42:30 UTC
No reaction...
I am marking this invalid, since it is not a bug but a change in behaviour.
There has been discusion wheter one wants to use a linked in rpath or not.
For now, we don't. Maybe I will provide a configure option in the future.

Michael