Bug 5302 - Large Site - Cups high cpu utilization after upgrade from 3.0.10
Large Site - Cups high cpu utilization after upgrade from 3.0.10
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Printing
3.0.28
All Linux
: P3 minor
: none
Assigned To: Gerald (Jerry) Carter
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-04 06:19 UTC by Adrian Sender
Modified: 2008-03-19 17:40 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adrian Sender 2008-03-04 06:19:28 UTC
status query from smbd->cups server which has changed api.

Large site(s) upgrade from 3.0.10 to 3.0.25 (also tested 3.0.28) causes high cpu usage in cups; even when no one is printing. Cpu usage hovers around 20-50% usage with approximately 80+ printers.

Have changed some configuration options such as the following which lower load slightly.

- cupsd.conf
BrowseInterval 1800
BrowseTimeout 5400

- smb.conf
lpq cache time = 900 #30
printcap cache time = 900

The cups access_log is also growing rapidly; approx 50 messages per a second. We have sent these to /dev/null for the time been.

Please investigate and fix.

Regards,

Adrian Sender.
Comment 1 Adrian Sender 2008-03-19 17:40:18 UTC
This was caused by not having comment and description field set for printers; samba would query cups for the information instead of local database.