Bug 5262 - authentication totally fails without -M single
authentication totally fails without -M single
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
Other Linux
: P3 regression
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 04:10 UTC by Samjam
Modified: 2008-02-15 04:36 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samjam 2008-02-15 04:10:12 UTC
bin/smbd -d 10 -i M single 
works fine when smbclient '\\sergio\test' is invoked from another machine. We get this debug output on the server by the time the client shows the password prompt:

smbsrv_accept
smbsrv_recv
Shutdown SMB signing
switch message SMBnegprot (task_id 31)
Requested protocol [0][PC NETWORK PROGRAM 1.0]
Requested protocol [1][MICROSOFT NETWORKS 1.03]
Requested protocol [2][MICROSOFT NETWORKS 3.0]
Requested protocol [3][LANMAN1.0]
Requested protocol [4][Windows for Workgroups 3.1a]
Requested protocol [5][LM1.2X002]
Requested protocol [6][DOS LANMAN2.1]
Requested protocol [7][LANMAN2.1]
Requested protocol [8][Samba]
Requested protocol [9][NT LANMAN 1.0]
Requested protocol [10][NT LM 0.12]
gendb_search_v: cn=Primary Domains (&(flatname=UFOMECHANIC)(objectclass=primaryDomain)) -> 1
Starting GENSEC mechanism spnego
Starting GENSEC submechanism gssapi_krb5
Added SERGIO$@UFOMECHANIC.NET(kvno 2) to keytab (des-cbc-md5)
Added SERGIO$@UFOMECHANIC.NET(kvno 2) to keytab (aes256-cts-hmac-sha1-96)
Added SERGIO$@UFOMECHANIC.NET(kvno 2) to keytab (des3-cbc-sha1)
Added SERGIO$@UFOMECHANIC.NET(kvno 2) to keytab (arcfour-hmac-md5)
using SPNEGO
Selected protocol [9][NT LANMAN 1.0]

(that debug output is written to the console and nothing in any log files)

however,
 bin/smbd -d 10 -i 
does not work, for when the same smbclient is invoke the only debug output generated for the client session by the time the client displays the password prompt is in /var/log/samba/sergio.log which shows:
[2008/02/15 10:05:12, 0] smbd/password.c:server_cryptkey(1054)
  password server not available

once for each time smbclient is run on the remote host.
not smbsrv_accept is even logged anywhere I can see.

smbclient fails with this error:
Connection to \\sergio\test failed - NT_STATUS_INVALID_PARAMETER
no matter what password is entered.


The problem _may_ be host specific because a build that works on one host fails when make-installed on a "similar" centos5 installation.
Comment 1 Samjam 2008-02-15 04:36:55 UTC
Sorry, mistake, smbclient was running on another window of the same machine which explains where the sergio.log came from - it was from smbclient.

Anyway, its a false alarm, I had a copy of samba2 running was well (don't ask! but still puzzling that -M single made it work!!!!)