Bug 5239 - Office 2007 gives "File already in use" when saving documents
Office 2007 gives "File already in use" when saving documents
Status: RESOLVED INVALID
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.0
x86 Windows XP
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-02 11:15 UTC by AndreGround
Modified: 2008-02-03 12:50 UTC (History)
0 users

See Also:


Attachments
Wireshark dump (236.35 KB, application/octet-stream)
2008-02-02 11:17 UTC, AndreGround
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description AndreGround 2008-02-02 11:15:34 UTC
Hi,
every time we try to save a document using Office 2007, we get a "File already in use" error. It happens on different servers with same kernel/samba config.

uname -a:
Linux hulk 2.6.20-1.3002.fc6xen #1 SMP Mon Aug 13 14:21:09 EDT 2007 i686 athlon i386 GNU/Linux

Samba version 3.0.28 compiled from tar.gz with line:
./configure --prefix=/usr --localstatedir=/var --with-configdir=/etc/samba --with-privatedir=/etc/samba/private --with-lockdir=/var/lock --with-piddir=/var/run --with-logfilebase=/var/log --with-smbmount --with-utmp --with-syslog --with-acl-support 

smb.conf
[root@hulk samba]# cat /etc/samba/smb.conf
[global]

        workgroup = MYGROUP
        server string = Samba Server Version %v

;       netbios name = MYSERVER

;       interfaces = lo eth0 192.168.12.2/24 192.168.13.2/24
;       hosts allow = 127. 192.168.12. 192.168.13.


        # logs split per machine
        log file = /var/log/samba/log.%m
        # max 50KB per log file, then rotate
        max log size = 50

        security = user
        passdb backend = tdbsam

        map acl inherit = yes
[homes]
        comment = Home Directories
        browseable = no
        writable = yes
        valid users = %S
        valid users = MYDOMAIN\%S

Wireshark dump attached (client side)
Comment 1 AndreGround 2008-02-02 11:17:17 UTC
Created attachment 3131 [details]
Wireshark dump

This is a trace of a normal session.
Log in, file opening then:
1) save from application (fails)
2) close and save (fails)
3) discard changes
Comment 2 AndreGround 2008-02-02 11:21:41 UTC
Same config with FC8 is running fine.

smbstatus on fc8 (prior saving):
amba version 3.0.28-0.fc8
PID     Username      Group         Machine                        
-------------------------------------------------------------------
 2152   andrea        andrea        macbookdru   (10.211.55.5)

Service      pid     machine       Connected at
-------------------------------------------------------
IPC$         2152   macbookdru    Sat Feb  2 17:19:44 2008
andrea       2152   macbookdru    Sat Feb  2 15:29:23 2008
IPC$         2152   macbookdru    Sat Feb  2 15:29:21 2008

Locked files:
Pid          Uid        DenyMode   Access      R/W        Oplock           SharePath   Name   Time
--------------------------------------------------------------------------------------------------
2152         500        DENY_NONE  0x100001    RDONLY     NONE             /home/andrea   .   Sat Feb  2 15:29:23 2008
2152         500        DENY_WRITE 0x3019f     RDWR       NONE             /home/andrea   ~$Nuovo Foglio di lavoro di Microsoft Office Excel.xlsx   Sat Feb  2 17:19:47 2008
2152         500        DENY_WRITE 0x2019f     RDWR       NONE             /home/andrea   Nuovo Foglio di lavoro di Microsoft Office Excel.xlsx   Sat Feb  2 17:19:47 2008
2152         500        DENY_NONE  0x20089     RDONLY     NONE             /home/andrea   Nuovo Foglio di lavoro di Microsoft Office Excel.xlsx   Sat Feb  2 17:19:47 2008

smbstatus on FC6 (prior saving):
Samba version 3.0.28
PID     Username      Group         Machine
-------------------------------------------------------------------
15646   enrico        ufficio       vecchio_enrico (192.168.100.35)

Service      pid     machine       Connected at
-------------------------------------------------------
ENRICO       15646   vecchio_enrico  Sat Feb  2 18:08:26 2008

Locked files:
Pid          Uid        DenyMode   Access      R/W        Oplock           SharePath   Name   Time
--------------------------------------------------------------------------------------------------
15646        500        DENY_WRITE 0x3019f     RDWR       EXCLUSIVE+BATCH  /home/enrico   ~$Nuovo Foglio di lavoro di Microsoft Office Excel.xlsx   Sat Feb  2 18:20:43 2008
15646        500        DENY_WRITE 0x2019f     RDWR       NONE             /home/enrico   Nuovo Foglio di lavoro di Microsoft Office Excel.xlsx   Sat Feb  2 18:20:42 2008
15646        500        DENY_NONE  0x100001    RDONLY     NONE             /home/enrico   .   Sat Feb  2 18:08:26 2008
Comment 3 AndreGround 2008-02-03 12:50:12 UTC
Finally discovered that the issue was caused by BitDefender Internet Security v10. Did an update to V11 and everything works fine now.