Bug 522 - wrong size for large file (smbfs)
wrong size for large file (smbfs)
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0
All Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 11:45 UTC by Danil Chapovalov
Modified: 2005-11-14 09:29 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Danil Chapovalov 2003-09-26 11:45:42 UTC
Both server and client has samba3.0.0
in a directory mounted with smbmount 
file size is shown as 18446744072531735073 (0xFFFFFFFFB9CBF221)
while real file size is 3117150753 (0xB9CBF221)
client use linux kernel v2.4.22 with builtin smbfs (not as a module).

smbclient on the same linux client computer shows correct usage
win2000(client) also shows the correct usage of the same file.
Comment 1 Andrew Bartlett 2003-09-26 18:09:08 UTC
There isn't anything 'Samba' can do to fix this.  

smbfs is a kernel module, and is not distributed by the Samba Team - we just
distribute a user-space 'helper' to get the process started.  

The problem is that smbfs does not have good 'large file' support.  I'm not sure
if this particular issue is indended to be fixed or not, but is now a
replacement - the CIFS VFS:

http://www.samba.org/samba/Linux_CIFS_client.html

In particular, the CIFS VFS does a much better job of handling connections to
Win2k3, and handles locking etc.

Comment 2 Gerald (Jerry) Carter 2005-11-14 09:29:17 UTC
database cleanup