Bug 5205 - 4.0_alpha torture crash
4.0_alpha torture crash
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
x86 Linux
: P3 major
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 08:40 UTC by Carl Dubois
Modified: 2008-08-14 12:40 UTC (History)
1 user (show)

See Also:


Attachments
4.0 smbtorture crash running under gdb. (5.13 KB, text/plain)
2008-01-18 11:42 UTC, Carl Dubois
no flags Details
retry with bt full (9.14 KB, text/plain)
2008-01-23 09:42 UTC, Carl Dubois
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carl Dubois 2008-01-16 08:40:35 UTC
Attempted to run 4.0-alpha smbtorture BENCH-NBENCH using a client file from:

http://samba.org/ftp/unpacked/cifs-load-gen/source/clients/

crashed gdb backtrace attached:

Any assistance appreciated. Thanks
Carl

[root@netbench16 bin]# ./smbtorture //10.60.100.101/Tbench2 -W engsmoke -U admin1%"pass()wd" --num-ops=1 --loadfile client_plain_massaged.txt BENCH-NBENCH
Using seed 1200493467
Running for 600 seconds with load 'client_oplocks.txt' and warmup 30 secs
Starting 4 clients
4 clients started
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
INTERNAL ERROR: Signal 11 in pid 19397 (4.0.0alpha1)
Please read the file BUGS.txt in the distribution
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
PANIC: internal error
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
INTERNAL ERROR: Signal 11 in pid 19399 (4.0.0alpha1)
Please read the file BUGS.txt in the distribution
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
PANIC: internal error
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
INTERNAL ERROR: Signal 11 in pid 19400 (4.0.0alpha1)
Please read the file BUGS.txt in the distribution
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
PANIC: internal error
BACKTRACE: 18 stack frames:
 #0 ./smbtorture(call_backtrace+0x27) [0x8767fb7]
 #1 ./smbtorture(smb_panic+0x1fa) [0x876827f]
 #2 ./smbtorture [0x87683bb]
 #3 ./smbtorture [0x87683f3]
 #4 /lib/tls/libc.so.6 [0xa38898]
 #5 /lib/tls/libc.so.6(strtoll+0x3e) [0xa3cbde]
 #6 ./smbtorture [0x80f353a]
 #7 ./smbtorture(torture_create_procs+0x26e) [0x8461627]
 #8 ./smbtorture [0x80f4013]
 #9 ./smbtorture [0x80bcc7b]
 #10 ./smbtorture [0x80bc7ce]
 #11 ./smbtorture(torture_run_tcase+0xd1) [0x80bc9a0]
 #12 ./smbtorture [0x80ba12c]
 #13 ./smbtorture [0x80b9fb9]
 #14 ./smbtorture [0x80ba209]
 #15 ./smbtorture [0x80bbb1c]
 #16 /lib/tls/libc.so.6(__libc_start_main+0xd3) [0xa25de3]
 #17 ./smbtorture [0x80b9e95]
BACKTRACE: 18 stack frames:
 #0 ./smbtorture(call_backtrace+0x27) [0x8767fb7]
 #1 ./smbtorture(smb_panic+0x1fa) [0x876827f]
 #2 ./smbtorture [0x87683bb]
 #3 ./smbtorture [0x87683f3]
 #4 /lib/tls/libc.so.6 [0xa38898]
 #5 /lib/tls/libc.so.6(strtoll+0x3e) [0xa3cbde]
 #6 ./smbtorture [0x80f353a]
 #7 ./smbtorture(torture_create_procs+0x26e) [0x8461627]
 #8 ./smbtorture [0x80f4013]
 #9 ./smbtorture [0x80bcc7b]
 #10 ./smbtorture [0x80bc7ce]
 #11 ./smbtorture(torture_run_tcase+0xd1) [0x80bc9a0]
 #12 ./smbtorture [0x80ba12c]
 #13 ./smbtorture [0x80b9fb9]
 #14 ./smbtorture [0x80ba209]
 #15 ./smbtorture [0x80bbb1c]
 #16 /lib/tls/libc.so.6(__libc_start_main+0xd3) [0xa25de3]
 #17 ./smbtorture [0x80b9e95]
BACKTRACE: 18 stack frames:
 #0 ./smbtorture(call_backtrace+0x27) [0x8767fb7]
 #1 ./smbtorture(smb_panic+0x1fa) [0x876827f]
 #2 ./smbtorture [0x87683bb]
 #3 ./smbtorture [0x87683f3]
 #4 /lib/tls/libc.so.6 [0xa38898]
 #5 /lib/tls/libc.so.6(strtoll+0x3e) [0xa3cbde]
 #6 ./smbtorture [0x80f353a]
 #7 ./smbtorture(torture_create_procs+0x26e) [0x8461627]
 #8 ./smbtorture [0x80f4013]
 #9 ./smbtorture [0x80bcc7b]
 #10 ./smbtorture [0x80bc7ce]
 #11 ./smbtorture(torture_run_tcase+0xd1) [0x80bc9a0]
 #12 ./smbtorture [0x80ba12c]
 #13 ./smbtorture [0x80b9fb9]
 #14 ./smbtorture [0x80ba209]
 #15 ./smbtorture [0x80bbb1c]
 #16 /lib/tls/libc.so.6(__libc_start_main+0xd3) [0xa25de3]
 #17 ./smbtorture [0x80b9e95]
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
INTERNAL ERROR: Signal 11 in pid 19398 (4.0.0alpha1)
Please read the file BUGS.txt in the distribution
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
PANIC: internal error
BACKTRACE: 18 stack frames:
 #0 ./smbtorture(call_backtrace+0x27) [0x8767fb7]
 #1 ./smbtorture(smb_panic+0x1fa) [0x876827f]
 #2 ./smbtorture [0x87683bb]
 #3 ./smbtorture [0x87683f3]
 #4 /lib/tls/libc.so.6 [0xa38898]
 #5 /lib/tls/libc.so.6(strtoll+0x3e) [0xa3cbde]
 #6 ./smbtorture [0x80f353a]
 #7 ./smbtorture(torture_create_procs+0x26e) [0x8461627]
 #8 ./smbtorture [0x80f4013]
 #9 ./smbtorture [0x80bcc7b]
 #10 ./smbtorture [0x80bc7ce]
 #11 ./smbtorture(torture_run_tcase+0xd1) [0x80bc9a0]
 #12 ./smbtorture [0x80ba12c]
 #13 ./smbtorture [0x80b9fb9]
 #14 ./smbtorture [0x80ba209]
 #15 ./smbtorture [0x80bbb1c]
 #16 /lib/tls/libc.so.6(__libc_start_main+0xd3) [0xa25de3]
 #17 ./smbtorture [0x80b9e95]


Throughput -0 MB/sec
Comment 1 Andrew Bartlett 2008-01-16 21:55:48 UTC
I can't see the gdb backtrace, could you attach it?
Comment 2 Carl Dubois 2008-01-17 08:19:56 UTC
sorry, is you scroll down its there, not attached. it was part of stdout
Comment 3 Andrew Bartlett 2008-01-17 14:31:10 UTC
Please recompile with configure --enable-developer and run under gdb, so we might get the gdb backtrace.  

A real gdb backtrace contains an order of magnitude more information. 
Comment 4 Carl Dubois 2008-01-18 11:42:13 UTC
Created attachment 3114 [details]
4.0 smbtorture crash running under gdb.
Comment 5 Carl Dubois 2008-01-18 11:59:47 UTC
Attempting to compare smbtorture NBENCH w/ NETBENCH client running in Windows.
read somewhere samba 4.0 uses epoll notifications while 30 uses system. t/f?
will this impact performance? any assistance appreticated?
Thanks
Carl

Windows 43.524 Mbps
Linux samba 3.0.28:

[root@netbench16 bin]# ./smbtorture //10.60.100.101/Netbench2 -N 1 -O TCP_NODELAY IPTOS_LOWDELAY -W engsmoke -U admin1%"pass()wd" NBENCH
host=10.60.100.101 share=Netbench2 user=admin1 myname=netbench16
Did not find a test named IPTOS_LOWDELAY
Running NBENCH
1 clients started
   1     91843  7.10 MB/secc

dbench: 

[root@netbench16 dbench-3.04]# ./dbench -t 60 -D /mnt/tbench2 -c client.txt 1
dbench version 3.04 - Copyright Andrew Tridgell 1999-2004

Running for 60 seconds with load 'client.txt' and minimum warmup 12 secs
1 clients started
   1       244     9.27 MB/sec  warmup   1 sec   
   1       464     8.08 MB/sec  warmup   2 sec   
   1      1032     7.62 MB/sec  warmup   3 sec   
   1      2457     7.02 MB/sec  warmup   4 sec   
   1      4022     8.01 MB/sec  warmup   5 sec   
   1      5868     7.81 MB/sec  warmup   6 sec   
   1      7496     8.45 MB/sec  warmup   7 sec   
   1      9390     8.20 MB/sec  warmup   8 sec   
   1     10772     8.55 MB/sec  warmup   9 sec   
Comment 6 Jelmer Vernooij 2008-01-20 13:33:55 UTC
Sorry, the attached file does not contain a valid gdb backtrace. Did you "make clean" after running ./configure.developer ?
Comment 7 Andrew Bartlett 2008-01-20 20:26:41 UTC
You also need to type 'bt full' to get the backtrace we require. 
Comment 8 Carl Dubois 2008-01-23 09:42:30 UTC
Created attachment 3117 [details]
retry with bt full

lets try this. let me know.
Thanks
Comment 9 Matthias Dieter Wallnöfer 2008-06-07 12:50:25 UTC
Here any progress?
Comment 10 Matthias Dieter Wallnöfer 2008-08-02 08:54:53 UTC
Does the problem persist?
Comment 11 Matthias Dieter Wallnöfer 2008-08-14 11:35:43 UTC
No answer for awhile, so I'm going to close this. If the problem persists, please reopen with a good reason!
Comment 12 Carl Dubois 2008-08-14 12:40:15 UTC
Sorry for the lack of response. 
Never did determine a root cause as my priorities changed. 

Will reopen "with a good reason" if I get back on this.

Thanks 
Carl