Bug 5200 - File transfer stalls on other volumes than /
File transfer stalls on other volumes than /
Status: RESOLVED INVALID
Product: Samba 3.2
Classification: Unclassified
Component: File services
3.2.0
x86 Linux
: P3 major
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 15:42 UTC by tombert
Modified: 2008-02-25 14:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tombert 2008-01-14 15:42:32 UTC
The original smb.conf configuration is extended with:
[storage]
 comment = something
 path = /mnt/storage
 read only = No

Now, from an XP machine connecting to the home directory and copy a 1 GB file takes about 2 to 3 Minutes - ok. The same file from the storage share takes about 120 minutes. Replacing the path to /home/user/something and the file copy is fast again - So the problem is something with the other volume only.
Tried to ftp and copy 1 GB file from home and from /mnt/storage - both goes with 11 MB/sec fine.
The only difference is that /mnt/storage points to a software RAID5 array, both mounts are reiserfs.
Comment 1 Volker Lendecke 2008-02-25 14:26:11 UTC
I don't think this is a proper bug in Samba. Very likely it's some kind of configuration issue in your socket options, some reiserfs hickup or whatever. Without a lot more data (tcpdump, strace of the smbd, full smb.conf) we can't do much here.

Closing this bug as invalid, please do re-open if you have more information.

Volker