Bug 5197 - smbd dies shortly or immediately after starting.
smbd dies shortly or immediately after starting.
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
Sparc Solaris
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-01-14 09:04 UTC by rpaynter
Modified: 2009-05-22 01:20 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description rpaynter 2008-01-14 09:04:25 UTC
I am unable to get smbd to stay running using multiple versions of Samba.  I have tested this with Samba 3.0.23c, 3.0.25c, and 3.0.28, and get the same error with each version.

There are no error messages in any of the log files that I have been able to find related to this issue.

When I run smbd in interactive mode, I get the following error:

sys_getgrouplist: user [samba]
push_sec_ctx(0, 0) : sec_ctx_stack_ndx = 1
push_conn_ctx(0) : conn_ctx_stack_ndx = 0
setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
NT user token: (NULL)
UNIX token of user 0
Primary group is 0 and contains 0 supplementary groups
Illegal Instruction

When I run truss on the smbd process, I get the following output:

785:    door_info(20, 0xFFBFA258)                       = 0
785:    door_call(20, 0xFFBFA240)                       = 0
785:    brk(0x0043AD80)                                 = 0
785:    brk(0x00442D80)                                 = 0
785:        Incurred fault #1, FLTILL  %pc = 0x004220F0
785:          siginfo: SIGILL ILL_ILLOPC addr=0x004220F0
785:        Received signal #4, SIGILL [default]
785:          siginfo: SIGILL ILL_ILLOPC addr=0x004220F0

This is a show-stopper on at least one of our systems.  The output from 'uname -a' is: "SunOS nexus 5.9 Generic_122300-12 sun4u sparc SUNW,Sun-Fire-280R"
Comment 1 rpaynter 2008-01-14 09:10:18 UTC
The compile-time arguments are:

./configure --with-krb5=/usr/local --with-ads --with-ldap

I have also tried disabling shared libraries, and explicitly enabling static libraries, with the same result.

The compile-time arguments used for the static build are given below:

./configure --with-krb5=/usr/local --with-ads --with-ldap --disable-shared --enable-static

I am using gcc 3.4.6 as the compiler.
Comment 2 Volker Lendecke 2008-01-14 09:15:47 UTC
Can you try with a different compiler? An illegal instruction very much smells like a compiler bug. gcc 3.4 is quite old, and SUN also has a compiler available at no cost.

Comment 3 rpaynter 2008-01-14 10:27:06 UTC
I've not had any luck using Sun's compiler.  I'm downloading gcc 4.2.2 and the latest snapshot of 4.3.  Once I get either of those to compile, I'll recompile Samba and see what I get.
Comment 4 rpaynter 2008-01-24 13:41:55 UTC
I compiled the source code for 3.0.28 using gcc 4.2.2, and still get the same error: 'illegal instruction'.

I have the same issue when I use Sun's compiler (Sun Studio 11).  I'm going to try Sun's latest (Sun Studio 12 09/07, and see if that helps.
Comment 5 Björn Jacke 2008-12-17 18:34:06 UTC
any news on this? you should also make sure your krb5 stuff is compiled with a
sane compiler.
Comment 6 Björn Jacke 2009-05-22 01:20:56 UTC
no feedback for 6 months, closing this one.