Bug 5195 - Unable to join WinXP to domain
Unable to join WinXP to domain
Status: RESOLVED INVALID
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
x86 Linux
: P3 normal
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 07:26 UTC by Sergey Belyashov
Modified: 2008-06-03 04:22 UTC (History)
1 user (show)

See Also:


Attachments
smbd -i -d 5 output (50.95 KB, text/plain)
2008-01-13 07:27 UTC, Sergey Belyashov
no flags Details
/etc/bind/named.conf (2.18 KB, text/plain)
2008-01-13 07:31 UTC, Sergey Belyashov
no flags Details
/etc/bind/pri/test.org.zone (1.60 KB, text/plain)
2008-01-13 07:33 UTC, Sergey Belyashov
no flags Details
wireshark log of process (runned from host machine) (65.12 KB, application/octet-stream)
2008-01-14 01:01 UTC, Sergey Belyashov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Belyashov 2008-01-13 07:26:25 UTC
System is: Linux GentooLinux 2.6.22-gentoo-r5 #2 SMP Sun Jan 13 09:33:47 MSK 2008 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+ AuthenticAMD GNU/Linux
Working under VirtualBox 1.5.4.

I try both latest svn and alpha2 package.
I install samba using HOWTO (http://wiki.samba.org/index.php/Samba4/HOWTO). I do all that writen there:
cd source
for SVN ./autogen.sh
./configure
make proto all (pch without automatic dependencies does not work)
make install
cd /usr/local/samba/share/test
./provision --realm=test.org --domain=TEST --adminpass='test' --server-role='domain controller'

Next I edit /etc/resolv.conf, /etc/conf.d/named, /usr/local/samba/etc/smb.conf and /etc/bind/named.conf, add test.org.zone (generated by script) and restart named...
I run samba (samba 3 not installed) by: # smbd -i -d 5
I check share by smbclient command and by accessing from other computer - all works fine.
Next I try to enter Windows XP Pro into the new domain. After I enter login/pass of administrator WinXP thinks about 10 seconds and shows me error: "The specified server cannot perform the requested operation". Windows Event Log is clear.
Comment 1 Sergey Belyashov 2008-01-13 07:27:46 UTC
Created attachment 3094 [details]
smbd -i -d 5 output
Comment 2 Sergey Belyashov 2008-01-13 07:31:25 UTC
Created attachment 3095 [details]
/etc/bind/named.conf
Comment 3 Sergey Belyashov 2008-01-13 07:33:36 UTC
Created attachment 3096 [details]
/etc/bind/pri/test.org.zone
Comment 4 Matthias Dieter Wallnöfer 2008-01-13 15:07:20 UTC
Strange. Please create also a logfile with wireshark! Generally that provides more information.
Comment 5 Sergey Belyashov 2008-01-14 01:01:49 UTC
Created attachment 3097 [details]
wireshark log of process (runned from host machine)

192.168.0.130 - machine with samba and bind
192.168.0.131 - Windows XP Pro SP2

Also installed dependencies:
attr-2.4.32
acl-2.2.39
bind-9.4.1_p1 (berkdb idn ssl threads urandom -dlz -doc -ipv6 -ldap -mysql -odbc -postgres -resolvconf)
gnutls-2.0.4 (nls zlib -doc -guile -lzo)
readline-5.2_p2
Comment 6 Sergey Belyashov 2008-01-15 15:03:21 UTC
I try to repeat this on openSUSE 10.3. All results are same.
But I found: when I change computer name in the join dialog then joining is sucessfull. But in test.org/Computers shows previous computer name (which were before joining)
Comment 7 Andrew Bartlett 2008-01-16 21:55:10 UTC
I'm not sure what is going on here.  Could you start from a fresh provision, and capture the first join?

(This join shows is trying to re-enable the old account).  
Comment 8 Sergey Belyashov 2008-01-17 04:46:18 UTC
What I do:
1. Check and install dependencies (gnutls, readline, acl).
2. get samba (svn for example), run autogen.sh, configure, make proto all, and make install
3. Configure PATH environment variable
4. Run provision:
   # cd /usr/local/samba/share/setup;./provision --realm=TEST.ORG --domain=TEST --adminpass=test --server-role='domain controller'
5. Configure bind (copy test.org.zone and change named.conf)
6. Run bind and samba4
7. Run fresh installed Windows XP Pro SP2 called "WinXP-P4" (DNS settings already configured). Try join into domain. Previously it was be joined to workgroup NONE.

Also I think, that problem may caused by different cases of symbols or symbol '-' in the machine name. Only machies renamed to "WINXP", "WINXPP4", "WINXPVB", "NONE" successfuly joined to domain.
Comment 9 Matthias Dieter Wallnöfer 2008-06-02 14:46:51 UTC
How does it work now?
Comment 10 Sergey Belyashov 2008-06-03 03:55:47 UTC
I do not try later. :-)
Comment 11 Andrew Bartlett 2008-06-03 04:22:25 UTC
Closing as invalid until reporter reproduces.