Bug 5183 - -r --include= --exclude= broken for version>=3.0.0pre5?
-r --include= --exclude= broken for version>=3.0.0pre5?
Status: CLOSED DUPLICATE of bug 5182
Product: rsync
Classification: Unclassified
Component: core
x86 Linux
: P3 normal
: ---
Assigned To: Wayne Davison
Rsync QA Contact
Depends on:
  Show dependency treegraph
Reported: 2008-01-09 11:13 UTC by gabriele balducci
Modified: 2012-07-26 10:01 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description gabriele balducci 2008-01-09 11:13:28 UTC

I'm probably missing something (apologies if so), but this has worked
for me for years, and starting from 3.0.0pre5 has stopped working in a
way that smells of some kind of bug.

To reproduce the (possible) bug, set up the following scene.

Remote host/directory:     remote_host:/some/dir
Local host:                current directory containing file `foo'

(I'm assuming working passwordless ssh connection between local and
remote host)

From the directory containing the file foo I issue the following command:

  rsync -e ssh  -r --include='/foo' --exclude='*' ./ remote_host:/some/dir

Now: for versions <=3.0.0pre4 this copies foo to the remote host, but
for versions >=3.0.0pre5, foo is not copied any more.

Running the command in verbose mode does not throw any light into my
(lack of) knowledge:

  rsync -e ssh  -rvv --include='/foo' --exclude='*' ./ remote_host:/some/dir


    opening connection using: ssh remote_host rsync --server -vvre30.14i .  /some/dir
    sending incremental file list
    removing duplicate name . from file list (2)
    removing duplicate name . from file list (3)
    removing duplicate name . from file list (4)
    removing duplicate name . from file list (5)
    delta-transmission enabled
    total: matches=0  hash_hits=0  false_alarms=0 data=0

    sent 51 bytes  received 15 bytes  132.00 bytes/sec
    total size is 0  speedup is 0.00

I can add that all works nicely even with version>=3.0.0pre5 the other
way around: i.e.:

  rsync -e ssh  -r --include='/foo' --exclude='*' remote_host:/some/dir ./

copies remote_host:/some/dir/foo into local current directory, as I
was always used to obtain.

Am I doing something wrong or something has changed between 3.0.0pre4
and 3.0.0pre5?

I could not find any report on this in bugzilla, and this makes me
think I might be making some gross mistake, but, as I said, that used
to work for years and still perfectly works for versions<=3.0.0pre4.

I'm on linux (, i686)

I thank you very much in advance for any hint and, of course, for
making rsync available.

Comment 1 gabriele balducci 2008-01-09 11:15:55 UTC
oops, sorry for the duplicate
please delete
Comment 2 Wayne Davison 2008-01-09 14:10:21 UTC

*** This bug has been marked as a duplicate of 5182 ***
Comment 3 Björn Jacke 2012-07-26 10:01:26 UTC
*** Bug 9030 has been marked as a duplicate of this bug. ***