Bug 518 - share "NOBODY" exists when [homes] is shared
share "NOBODY" exists when [homes] is shared
Status: RESOLVED INVALID
Product: Samba 2.2
Classification: Unclassified
Component: User/Group Accounts
2.2.8a
All Solaris
: P3 critical
: ---
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 09:31 UTC by Robert Petty
Modified: 2005-11-14 09:31 UTC (History)
0 users

See Also:


Attachments
smb.conf file from system exhibiting behavior (2.74 KB, text/plain)
2003-09-29 08:28 UTC, Robert Petty
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Petty 2003-09-26 09:31:08 UTC
The default for sun is to set "nobody"s home directory to "/".  Even when not 
sharing "[homes]" we can access "\\servername\NOBODY" and until the home 
directory for nobody is altered, the entire filesystem is visible. There is no 
share in the smb.conf named "nobody" or anything even close to it.
Comment 1 Tim Potter 2003-09-28 22:20:03 UTC
Can you post your smb.conf file?

Do you have the 'map to guest' parameter set?

I've tried to reproduce this with a minimal smb.conf file but can't access a
share called NOBODY (fails with "tree connect failed: NT_STATUS_BAD_NETWORK_NAME").
Comment 2 Robert Petty 2003-09-29 08:28:14 UTC
Created attachment 171 [details]
smb.conf file from system exhibiting behavior
Comment 3 Andrew Bartlett 2003-12-31 18:36:51 UTC
The supplied smb.conf includes the [homes] share, so I presume this one is user
error.

This is a documented effect of the [homes] share, and the reason for the 'valid
users = %S' option.  Possibly this should be a default.
Comment 4 Gerald (Jerry) Carter 2005-11-14 09:31:12 UTC
database cleanup