Bug 5176 - mount.cifs only sees toplevel directory, even after cd to a subdirectory
mount.cifs only sees toplevel directory, even after cd to a subdirectory
Status: RESOLVED DUPLICATE of bug 4066
Product: CifsVFS
Classification: Unclassified
Component: kernel fs
2.6
x86 Linux
: P3 regression
: ---
Assigned To: Steve French
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 22:38 UTC by Jan Newmarch
Modified: 2008-09-04 13:26 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Newmarch 2008-01-06 22:38:49 UTC
Mounting a filesystem using "mount -t cifs..." "ls" shows the toplevel directory ok. "cd" works - and "pwd" shows I am in the subdir. But "ls" only shows the toplevel again. In fact, if one of the dirs is "X" I can do "cd X; cd X; cd X" and "pwd" shows "X/X/X". I cannot see the files in any subdirectory.

BUT smbclient works fine and I can change directories and see files. smbclient reports "Domain=[MAIL] OS=[Windows Server 2003 3790 Service Pack 1] Server=[Windows Server 2003 5.2]".

The problem has been the same for several versions of mount.cifs (versions supplied with Fedora Core 6 and 8, and also with Samba 3.0.28)
Comment 1 Steve French 2008-09-04 13:26:10 UTC
Let us know if this (bug fix for bug 4066) does not fix this)

*** This bug has been marked as a duplicate of 4066 ***