Bug 5155 - Samba not joining longhorn server in security = ads
Samba not joining longhorn server in security = ads
Status: RESOLVED FIXED
Product: Samba 3.2
Classification: Unclassified
Component: Client tools
3.2.0
x86 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-21 05:06 UTC by Magnus Mertens
Modified: 2008-02-07 08:28 UTC (History)
2 users (show)

See Also:


Attachments
smb.conf (294 bytes, text/plain)
2007-12-21 05:07 UTC, Magnus Mertens
no flags Details
krb5.conf (697 bytes, text/plain)
2007-12-21 05:08 UTC, Magnus Mertens
no flags Details
net-output (35.01 KB, text/plain)
2007-12-21 05:08 UTC, Magnus Mertens
no flags Details
tcpdump (23.68 KB, application/octet-stream)
2007-12-21 05:10 UTC, Magnus Mertens
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Magnus Mertens 2007-12-21 05:06:34 UTC
Trying to join Samba 3.2-test or 3.0.28 to a Windows 2008 Standard Domain Controller (Release Candidate 1) leads to failure NT_STATUS_INVALID_ACCOUNT_NAME ("Failed to join domain: Improperly formed account name".)

kinit received a valid kerberos ticket before. Running the same samba-setup with a Windows 2003 DC works.

Attached: smb.conf, krb5.conf, sniff and net-output with samba3.2-test
Comment 1 Magnus Mertens 2007-12-21 05:07:49 UTC
Created attachment 3061 [details]
smb.conf
Comment 2 Magnus Mertens 2007-12-21 05:08:03 UTC
Created attachment 3062 [details]
krb5.conf
Comment 3 Magnus Mertens 2007-12-21 05:08:55 UTC
Created attachment 3063 [details]
net-output
Comment 4 Magnus Mertens 2007-12-21 05:10:07 UTC
Created attachment 3064 [details]
tcpdump
Comment 5 Magnus Mertens 2008-02-07 08:28:33 UTC
seems to be fixed with the current 3.2-test checkout. tested with success with the same configuration today, thanks :-)