Bug 5133 - OS/2 disconnection to Samba 3.0.27 Server
OS/2 disconnection to Samba 3.0.27 Server
Product: Samba 3.0
Classification: Unclassified
Component: File Services
x86 Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
Depends on:
  Show dependency treegraph
Reported: 2007-12-09 02:01 UTC by Frank Ambacher
Modified: 2007-12-12 14:53 UTC (History)
0 users

See Also:

tcpdump tracefile (17.80 KB, application/octet-stream)
2007-12-09 02:07 UTC, Frank Ambacher
no flags Details
Level 10 degug log (695.71 KB, application/octet-stream)
2007-12-09 09:49 UTC, Frank Ambacher
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Ambacher 2007-12-09 02:01:37 UTC
Server: Samba 3.0.27, configured as PDC
Client: OS/2
Directly after OS/2 logs on the connection disconnects.

--- CUT ---
OS/2 Command Interpreter version 4.5

[D:\]net use x: \\samba\tauschen
The command completed successfully.



SYS0240: The network connection is disconnected.

Comment 1 Frank Ambacher 2007-12-09 02:07:25 UTC
Created attachment 3033 [details]
tcpdump tracefile
Comment 2 Volker Lendecke 2007-12-09 04:02:46 UTC
I've written a little test that does quite exactly what OS/2 does. No crash with 3.0.27. Can you please upload a full debug level 10 log of smbd leading to the crash?



P.S: The first one to show me a way to run OS/2 successfully under my linux here gets free entry to SambaXP 2008 :-)
Comment 3 Frank Ambacher 2007-12-09 09:49:44 UTC
Created attachment 3034 [details]
Level 10 degug log

Here are the requested level 10 debug log.
If you need further information let me know.
Also I'm interested to know where the problem is.
Comment 4 Volker Lendecke 2007-12-09 09:59:21 UTC
Can you retry with 3.0.27a?

Comment 5 Frank Ambacher 2007-12-09 10:19:24 UTC
The packages installed are from

If you know of newer binary packages, I'm willing to test it. In this case please submit a link.
Comment 6 Volker Lendecke 2007-12-09 10:34:22 UTC
Hmmm. Just had to find out that ftp.sernet.de does not have OpenSuSE 10.3 yet... Stay tuned, they will be available under http://ftp.sernet.de/pub/samba/recent/suse/10.3/

You're always free to compile Samba on your own or downgrade to 3.0.26a. I'm closing this bug because I'm pretty certain that this is the bug that led to 3.0.27a instead of 3.0.27. Please re-open if you can reproduce it with 3.0.27a.

Comment 7 Frank Ambacher 2007-12-09 10:42:00 UTC
Downgrading to 3.0.26a is no way to go for me. These packages are the original packages from Suse 10.3. I've the same result with it. This was the reason to update to 3.0.27.
Comment 8 Frank Ambacher 2007-12-12 14:47:17 UTC
Just want to let you know my OS/2 client now works after updating the server with
samba-3.0.28. Many thanks to Volker and the samba crew.