Bug 511 - Windows 2000 server with SP4 is NOT returning the old ldapServiceName
Windows 2000 server with SP4 is NOT returning the old ldapServiceName
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.0
Other other
: P3 normal
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks: 807
  Show dependency treegraph
 
Reported: 2003-09-25 16:20 UTC by Tim Potter
Modified: 2005-08-24 10:16 UTC (History)
0 users

See Also:


Attachments
Fix from reporter (2.57 KB, patch)
2003-09-25 16:22 UTC, Tim Potter
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Potter 2003-09-25 16:20:53 UTC
> Subject: patch for Samba 3.0.0, ldap.c
> From: "William G. Zereneh" <zereneh@scs.ryerson.ca>
> To: samba-patches@samba.org
> Organization: Ryerson University
> 
> Hello,
> 
> It appears that Windows 2000 server with SP4 is NOT returning the old
> ldapServiceName:
> vnet3.home.samba.org:win2000-vnet3$@VNET3.HOME.SAMBA.ORG
>
> it's returning:
> principal/instance@REALM
> 
> log from net
> %net ads join -d10
> 
> [2003/09/25 11:29:04, 3] libads/ldap.c:ads_server_info(1915)
>   got ldap server name host/ad.win.scs.ryerson.ca@WIN.SCS.RYERSON.CA,
> using bind
>
> Please see attachment for a fix.
>
> Great job Samba Team keep it up.
> --
> William G. Zereneh <zereneh@scs.ryerson.ca>
> Ryerson University
Comment 1 Tim Potter 2003-09-25 16:22:32 UTC
Created attachment 165 [details]
Fix from reporter
Comment 2 Gerald (Jerry) Carter 2004-11-11 11:03:04 UTC
is this still an issue in 3.0.8 ?  If there are no updates, I'm going 
to close this one soon.
Comment 3 Gerald (Jerry) Carter 2005-02-07 10:47:17 UTC
closing.
Comment 4 Gerald (Jerry) Carter 2005-08-24 10:16:11 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.