Bug 5094 - User, group and everyone always get read permission when editing ACLs
User, group and everyone always get read permission when editing ACLs
Status: RESOLVED DUPLICATE of bug 4929
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.27
x86 Linux
: P3 major
: none
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-20 09:58 UTC by Roel van Meer
Modified: 2008-02-19 06:15 UTC (History)
2 users (show)

See Also:


Attachments
Patch that comments out the code that seems to cause the problem (749 bytes, patch)
2007-11-20 10:04 UTC, Roel van Meer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roel van Meer 2007-11-20 09:58:05 UTC
When editing ACLs with the windows XP ACL editor, on applying any new settings the permissions for user, group and Everyone always include read access.
This happens with samba versions 3.0.25c and up.

I've tested this with very different configs and always seemed to get identical behaviour.
Comment 1 Roel van Meer 2007-11-20 10:04:20 UTC
Created attachment 2987 [details]
Patch that comments out the code that seems to cause the problem

This patch comments out some code in append_parent_acl(), which seems to be called from set_nt_acl() since the change that made posix_acl a vfs object. The cause seems to be a call to the unix_mode() function, which has documentation that states that "everybody gets read bit set". Because of this, whenever a parent acl is added, user, group and world always get read access.

The patch might not be correct or appropriate, but it fixes the trouble I have, so at the very least I hope it is helpful in tracking down this problem.
Comment 2 Roel van Meer 2007-11-20 10:05:13 UTC
I can provide level 10 debug logs if you need them; just let me know.
Comment 3 Gerald (Jerry) Carter 2007-11-20 10:08:13 UTC
Jeremy, Guessing this is related to the ACL propogation changes.
Comment 4 mvanraaij 2008-01-09 03:01:28 UTC
I have the same problem, is there going to be a patch for the nezt release?
Comment 5 Roel van Meer 2008-01-15 05:10:07 UTC
This bug is starting to be a real showstopper for me. Is there anything I can do to help?
Comment 6 Roel van Meer 2008-01-30 10:12:45 UTC
Might be related to bug # 4929, testing with the patches that fixed it.
Comment 7 Roel van Meer 2008-01-30 10:39:02 UTC
I tried 3.0.28 with both patches from bug # 4929 (comments 10 and 11). Those patches fix the problems, so I've closed this one as a duplicate.

*** This bug has been marked as a duplicate of 4929 ***
Comment 8 mvanraaij 2008-02-19 06:15:14 UTC
The problem is still here. I also tried the patches with no luck. This problem is not fixed in every situation.