Bug 5086 - Winbindd write to socket failed, but works with -d10
Winbindd write to socket failed, but works with -d10
Product: mod_auth_ntlm_winbind
Classification: Unclassified
Component: module
x86 Linux
: P3 normal
: ---
Assigned To: Samba Bugzilla Account
Gerald (Jerry) Carter
Depends on:
  Show dependency treegraph
Reported: 2007-11-15 10:41 UTC by Herman
Modified: 2014-04-21 15:41 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Herman 2007-11-15 10:41:31 UTC
Hi guys,
Here is a weird timing related problem (I guess) with winbindd and Samba 3.0.26a, recompiled from source for RedHat EL5, authenticating against Win2003SE2 AD.

I tend to get the error "pam_winbind_request: write to socket failed!" when I run winbindd normally.  This leads to "pam_winbind (su -l: auth): internal module error (retval = 3, user = 'root')".  This problem doesn't always happen.  It changes from day to day.

This problem leads to an enormous system slowdown.  Even a simple command like 'ls' will take minutes to execute.  I have seen other people complaining about the same thing here: http://www.infrant.com/forum/viewtopic.php?p=67430

If I kill winbindd, the system becomes responsive again, but then I cannot authenticate with AD at all of course.

However, when I run "winbindd -d10", the problem goes away!


Comment 1 Gerald (Jerry) Carter 2007-11-15 11:20:49 UTC
I'll try to look into this next week.
Comment 2 Herman 2007-11-15 15:24:51 UTC
OK, since I can compile the source, just let know what you need me to do, to help find the problem.  I have been reading code to try and figure it out, but so far I have no idea what is going wrong.
Comment 3 Lars Müller 2014-04-21 15:30:42 UTC
Please reopen if this is still the case with the current Samba 4.0 or 4.1 code base?

Have you consider to use the Apache mod_auth_kerb from http://modauthkerb.sourceforge.net/ instead?