Bug 506 - MYSQL pass backend reports relocation error
MYSQL pass backend reports relocation error
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: Build environment
3.0.0preX
All Linux
: P3 normal
: none
Assigned To: Jelmer Vernooij
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-25 06:14 UTC by Brian
Modified: 2005-11-14 09:30 UTC (History)
1 user (show)

See Also:


Attachments
This is the config.log that configure wrote (332.08 KB, text/plain)
2003-10-09 06:17 UTC, Brian
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian 2003-09-25 06:14:57 UTC
[2003/09/24 19:25:59, 1] passdb/pdb_mysql.c:mysqlsam_init(922) Connecting to 
database server, host: localhost, user: samba, password: , database: 
samba,port: 3306
/usr/local/samba-3.0.0RC4/sbin/smbd: relocation error: /usr/local/samba-
3.0.0RC4/lib/pdb/mysql.so: undefined symbol: mysql_init
/usr/local/samba-3.0.0RC4/sbin/smbd: relocation error: /usr/local/samba-
3.0.0RC4/lib/pdb/mysql.so: undefined symbol: mysql_init
Comment 1 Tim Potter 2003-09-25 16:17:35 UTC
Assigning to Jelmer
Comment 2 Jelmer Vernooij 2003-09-25 16:49:49 UTC
How did you compile pdb_mysql.so? Does ldd /usr/lib/samba/pdb/mysql.so show any
mysql library?
Comment 3 Brian 2003-09-26 05:10:14 UTC
ldd reports the following:

myusername@QorTek:/usr/local/samba/lib/pdb# ldd mysql.so
        libc.so.6 => /lib/libc.so.6 (0x40011000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

Comment 4 Jelmer Vernooij 2003-09-26 06:05:12 UTC
Have you run ./configure --with-expsam=mysql ?
Comment 5 Brian 2003-09-26 09:35:01 UTC
Here is my sanba_conf script file:
# !/bin/bash
#

./configure --prefix=/usr/local/samba-3.0.0RC4 \
            --localstatedir=/var/samba \
            --with-lockdir=/var/lock/samba \
            --with-piddir=/var/run/samba \
            --with-swatdir=/pub/web/swat-3.0.0RC4 \
            --with-mysql-prefix=/usr/local/mysql \
            --with-mysql-exec-prefix=/usr/local/mysql/bin \
            --with-smbmount=yes \
            --with-quotas=yes \
            --with-expsam=mysql \
            --without-ldap

Comment 6 Jelmer Vernooij 2003-10-07 19:01:33 UTC
Can you post your config.log ?
Comment 7 Brian 2003-10-09 06:17:31 UTC
Created attachment 191 [details]
This is the config.log that configure wrote

Note: that ./configure thinks that mysql_config is located in
/usr/local/mysql/bin/bin/mysql_config and does not fail.

This file does not exist, however, /usr/local/mysql/bin/mysql_config does
Comment 8 Jelmer Vernooij 2003-10-09 13:25:21 UTC
try --with-mysql-exec-prefix=/usr/local/mysql instead of 
--with-mysql-exec-prefix=/usr/local/mysql/bin
Comment 9 Jelmer Vernooij 2003-10-19 11:01:42 UTC
This was a user error, not a bug.
Comment 10 Gerald (Jerry) Carter 2005-02-07 09:05:47 UTC
originally reported against one of the 3.0.0rc[1-4] releases.
Cleaning up non-production versions.
Comment 11 Gerald (Jerry) Carter 2005-11-14 09:30:32 UTC
database cleanup