Bug 5041 - ADUC: Move operations
ADUC: Move operations
Product: Samba 4.0
Classification: Unclassified
Component: Other
Other All
: P3 normal
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
Depends on:
  Show dependency treegraph
Reported: 2007-10-25 04:23 UTC by Matthias Dieter Wallnöfer
Modified: 2007-10-31 17:48 UTC (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-10-25 04:23:19 UTC
The new subtree operations, which seem to work now in a good manner, have maybe broken the "move" operation. So in ADUC I cannot move objects anymore (before I was able to). Could you try to look at it?
Comment 1 Andrew Bartlett 2007-10-25 05:33:10 UTC
Yep, and the testsuite proves it.  I'll look at it tomorrow. 

Comment 2 Andrew Bartlett 2007-10-25 06:08:09 UTC
Fixed in -r 25729.
Comment 3 Matthias Dieter Wallnöfer 2007-10-25 08:44:36 UTC
Another issue: when you move a OU and choose in the destination dialog the same one, the object disappears. I think, that can't be correct!
Comment 4 Matthias Dieter Wallnöfer 2007-10-29 07:45:07 UTC
Have you checked my bug?
Comment 5 Andrew Bartlett 2007-10-30 00:16:56 UTC
Very weird.  I'll add that case to the testsuite. 
Comment 6 Matthias Dieter Wallnöfer 2007-10-31 17:36:41 UTC
I'm now satisfied with the latest SVN. Another troublesome bug fixed and one fewer. I think, the error message which is displayed now is ok.
Comment 7 Andrew Bartlett 2007-10-31 17:48:20 UTC
Thankyou very much for you testing and patience.   We are closer to being a sane ldap server every day...