Bug 5013 - Strange file rights behaviour create mask vs. security mask
Strange file rights behaviour create mask vs. security mask
Status: NEW
Product: Samba 3.0
Classification: Unclassified
Component: Config Files
3.0.24
x86 Linux
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 02:32 UTC by Sysadmin HTL-Leonding
Modified: 2008-03-20 04:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sysadmin HTL-Leonding 2007-10-08 02:32:32 UTC
I have tried this with this versions on a Gentoo system, but I also tried this on a SuSE OES 9 SP2 without any other patches and it didn't work either.

I'm trying to mount files via cifs (kernel 2.6.21) from our Samba Server. Everything works fine until I create a new file. This file doesn't have the execute-Flag set and I'm unable to set it.

If I set the create mask to 0777 then the files are created with the x-Flag set and I can set and unset it, but this isn't what I wanted (they shouldn't have permissions 0777 per default, it should only be possible to set them to 0777 if the user wants to).

If I only set the security mask to 0777 (being the default as stated in the man-page) (without setting the create mask) then I'm unable to activate the x-Flag.

Maybe I haven't understood the documentation and it is my fault. Then please excuse the stupid bug report, but please tell me how to do it right.
Comment 1 Sysadmin HTL-Leonding 2007-10-08 02:40:38 UTC
I tried this using the homes-export

//sambasrv/username


extract from smb.conf:
[homes]
comment = Home Directories
valid users= %U
read only = no
create mask = 0664
directory mask = 0775
browseable=no 
admin users=@adminstaff

If I would change the create mask to 0764, users could set the x-flag, but on every new file the x-file would be also set, which isn't what I want