Bug 5007 - smbd/reply.c
smbd/reply.c
Status: RESOLVED DUPLICATE of bug 5006
Product: Samba 3.2
Classification: Unclassified
Component: Build environment
3.2.0
All Linux
: P3 regression
: ---
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-04 08:28 UTC by Joerg.Bernau@web.de
Modified: 2007-10-04 08:35 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joerg.Bernau@web.de 2007-10-04 08:28:56 UTC
Hi all!

a little bugfix:

-- smbd/reply.c.orig   2007-10-04 14:58:46.000000000 +0200
+++ smbd/reply.c        2007-10-04 14:57:48.000000000 +0200
@@ -3923,7 +3923,7 @@
                if(IVAL(req->inbuf,smb_vwv12) != 0) {
                        DEBUG(0,("reply_write_and_X - large offset (%x << 32) "
                                 "used and we don't support 64 bit offsets.\n",
-                                (unsigned int)IVAL(inbuf,smb_vwv12) ));
+                                (unsigned int)IVAL(req->inbuf,smb_vwv12) ));
                        reply_doserror(req, ERRDOS, ERRbadaccess);
                        END_PROFILE(SMBwriteX);
                        return;

yours 

joerg
Comment 1 Volker Lendecke 2007-10-04 08:35:44 UTC

*** This bug has been marked as a duplicate of 5006 ***