Bug 5000 - smbclient returning 'string length'+1 of the first character of the share name
smbclient returning 'string length'+1 of the first character of the share name
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: smbclient
3.0.26a
Other Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 23:42 UTC by Shawn Stricker
Modified: 2008-02-02 20:55 UTC (History)
1 user (show)

See Also:


Attachments
Samba log file @ log level = 10 (257.94 KB, application/octet-stream)
2007-10-04 21:41 UTC, Shawn Stricker
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shawn Stricker 2007-09-30 23:42:34 UTC
on my debian etch the samba server is returning 'string length'+1 of the first character of the share name. no matter which machine or version that requests the share list it always returns the same value.

$ smbclient -L //localhost/
Domain=[NAS] OS=[Unix] Server=[Samba 3.0.26a]

        Sharename       Type      Comment
        ---------       ----      -------
        TTTTTTTTTTTT    Disk      
        llllll          Disk      
        IIIII           IPC       IIIIIIIIIIIIIIIIIIIIIIIII
Domain=[NAS] OS=[Unix] Server=[Samba 3.0.26a]

        Server               Comment
        ---------            -------

        Workgroup            Master
        ---------            -------
        WORKGROUP            

$cat /etc/samba/smb.conf

[global]
        dos charset =CP850
        unix charset = UTF-8
        display charset = LOCALE
        server string = %h server
        obey pam restrictions = Yes
        passdb backend = tdbsam
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
        syslog only = Yes
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        ldap ssl = no
        panic action = /usr/share/samba/panic-action %d
        invalid users = root

[TimeMachine]
        path = /srv/timemachine
        valid users = shawn
        read only = No
[local]
        path = /srv/timemachine
        valid users = shawn
        read only = No


$ sudo locale -a    
C
POSIX

$ testparm -v -s | grep charset
Load smb config files from /etc/samba/smb.conf
Processing section "[TimeMachine]"
Processing section "[local]"
Loaded services file OK.
Server role: ROLE_STANDALONE
        dos charset = CP850
        unix charset = UTF-8
        display charset = LOCALE
Comment 1 Shawn Stricker 2007-10-04 21:41:07 UTC
Created attachment 2937 [details]
Samba log file @ log level = 10

the attached log file is the result of a fresh start of smbd and running smbclient -L //localhost  after updating my smb.conf it looks like this: [global]
        dos charset =CP850
        unix charset = ASCII
        display charset = LOCALE
        server string = %h server
        obey pam restrictions = Yes
        passdb backend = tdbsam
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
        log file = /var/log/samba/samba.log
        log level = 10
        max log size = 1000
        dns proxy = No
        ldap ssl = no
        panic action = /usr/share/samba/panic-action %d
        invalid users = root

[TimeMachine]
        path = /srv/timemachine
        valid users = shawn
        read only = No
[local]
        path = /srv/timemachine
        valid users = shawn
        read only = No

[homes]
        comment = Home Directories
        valid users = %S
        read only = No
        browseable = No
Comment 2 Volker Lendecke 2007-10-05 00:48:44 UTC
What platform is this? Just curious..

Volker
Comment 3 Volker Lendecke 2007-10-05 07:18:04 UTC
14:14        kukks > vl: Hi! Regarding bugzilla #5000. The Hardware is a NAS 
                     box running debian etch -  "Processor       : 
                     XScale-IXP42x Family rev 1 (v5l)   Hardware        : 
                     Linksys NSLU2"
Comment 4 Volker Lendecke 2007-10-05 07:28:13 UTC
Is this a self-compiled Samba, or is it shipped by the NAS vendor? Does the box have a compilation environment installed? I would need to step through smbd with a debugger, thus I would need login.

Volker
Comment 5 Shawn Stricker 2007-10-05 12:50:25 UTC
I installed 3.0.26a from debian etch onto this box using the normal package system. I can give you login access. Or ask kukks since I gave him login credentials which until this is issue is resolved will remain valid
Comment 6 Volker Lendecke 2007-10-05 14:28:55 UTC
Well, with just standard .deb's without debugging symbols and source code I don't see much chance to find this. If I was you I would raise this as a debian packaging problem.

Sorry to reject this, but to find this type of problem essentially a developer needs such a box with a build environment.

Volker
Comment 7 Volker Lendecke 2007-10-06 16:37:57 UTC
Just finished testing a plain ./configure; make compiled samba 3.0.26a on that box, and the error does not happen. So I'd call this a debian packaging problem. I'm leaving this bug open for reference by a corresponding debian bug.

Volker
Comment 8 Shawn Stricker 2007-10-06 17:58:06 UTC
Since Volker Lendecke determined that i was a problem with the debian package or configuration I have created:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=445566
Comment 9 Shawn Stricker 2008-02-02 20:54:46 UTC
Issue was caused by an arm compiler problem by building rpc_parse/parse_prs.o with -O0 on this architecture.

It has been resolved on the ARM architecture but is still open on armel. Since this is fully isolated to a gcc issue closing this ticket.