Bug 4990 - RPC Server unavailable & cannot verify server is part of a domain
RPC Server unavailable & cannot verify server is part of a domain
Product: Samba 4.0
Classification: Unclassified
Component: Other
x86 Linux
: P3 normal
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
Depends on:
  Show dependency treegraph
Reported: 2007-09-24 10:33 UTC by Jason Tarbet
Modified: 2008-06-07 12:52 UTC (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Jason Tarbet 2007-09-24 10:33:42 UTC
Archlinux(2.6.22-ARCH #1 SMP PREEMPT) with the most recent Samba4 SVN code compiled.

When I try and log into my domain (as domain administrator from a winxp2sp2 machine) I can log in fine, I can load the dsa.msc and other domain controller plugins fine - the Samba ADS is found, I can move users and see their information.  However if I try to change the user's group, or use any of the tools to manipulate the group policy, I get a couple different errors.

#1 The program cannot open the required dialog box because it cannot determine whether the computer named "server.domain.tld" is joined to a domain.  (it is obviously the domain controller)

and just following that message I get:
#2 The RPC server is unavailable.  ( I also get this message trying to add my domain in the group policy plugin - This however is the only error that pops up unlike the above error - and I can still do nothing there)

When I log into SWAT it says that the server is running fine.  I can connect to shares and do most other functions just fine. Although with the most recent SWAT updates I am now getting an error on the ldb esp page & will not return my ldb information like it did from the original Samba4 Alpha.

This error looks like this:

Samba4 ldb test
An attribute constrained search
An unconstrained search
A search with bad arguments

ldb.search malformed base dn
	[ 0]                     :31   -> res = ldb.search("=blah", "foo")

And I don't know if I should be creating separate bugs for all of these, but on the samr.esp page, There is no way to scroll down through the information, it stops you with whatever it can fit in a page, even though there is more information obviously continued below.

Of note, I do not know if it matters to samba, but my dns is hosted off another machine entirely, but has been setup according to the generated file(also - my Bind setup (9.4.1-2) would not accept the tkey-gssapi-credential setting from the sample named.conf)
Comment 1 Jason Tarbet 2007-09-24 11:44:25 UTC
I forgot to say that the latest SVN revision I was running was 25305.
Comment 2 Matthias Dieter Wallnöfer 2007-09-25 03:05:57 UTC
Are you probably using a client other than one with US american english language? Then you have to change the display specifiers in AD (bug 4794).
Comment 3 Jason Tarbet 2007-09-25 06:13:15 UTC
Everything I am using is American English. All the snap-ins are US-Eng, and the samba4 was compiled on my system with my environment variables.  I checked the display_specifiers file and all I can see is CN=409

Am I correct in assuming that according to the link you sent(with it's attached reference) that it should indeed be CN=409?
Comment 4 Jason Tarbet 2007-09-25 06:14:14 UTC
nevermind, I think I misread that.  It should be 407, correct?
Comment 5 Jason Tarbet 2007-09-25 06:20:47 UTC
scratch that. 409 is US english and I did have it correct.  so where else might the problem lie? 

Little more info:

I was actually able to see users in swat (previous to the most recent updates) but it would happen intermittently.  I would sometimes get a dialogbox that poppped up with some text in it that looked a bit like it was displaying part of the search code.

I really hope that I didn't miss something while reading through the previously posted bugs.  I tried to read as many as I could that even contained a couple of the words.
Comment 6 Andrew Bartlett 2007-09-25 16:19:50 UTC
Please file the different issues into different bugs. 

This will allow me to then note that the SWAT issues are largely 'WONTFIX' (I just need to cull out the bits we don't need/use or don't work).
Comment 7 Matthias Dieter Wallnöfer 2007-12-08 14:01:55 UTC
Are the problems persisting in recent SVN releases?
Comment 8 Jason Tarbet 2007-12-10 08:44:08 UTC
Actually most have gotten worse.  I now cannot even properly install the domain, this includes after repeated complete removal, compilation, reinstallation and domain recreation.  I will try to take the time this week to give a break down of all of what I've seen happen with the most recent releases.

briefly: trying to provision through the web interface returns an error stating that the Domain name needs to match the expected result of NULL from smb.conf.  logging into the domain from a PC will not find the network path. either with realm or the domain. although I am going to verify that this isn't a nameserver issue before I blame samba.

provisioning from console works.  I will get the latest working code as soon as there is one that will compile and install and let you know.

Comment 9 Andrew Bartlett 2007-12-10 19:55:31 UTC
The SWAT issues are quite seperate to the other problems, and need to be reported separately.  I am looking into this area (or the option of completely dumping SWAT). 
Comment 10 Jason Tarbet 2007-12-11 08:00:22 UTC
on provisioning I am getting a DNS provisioning failure and no generated file to copy to named.conf which also keeps me from then joining the domain.

is there a different way you want me to handle bugs?  Personally I don't have the time to open up an individual bug report for every glitch I come across(and I know that if there is going to be a bug report that's the way it should be. however I am pretty quick with testing and responses and the occasional idea/fix.  I could hang out in samba-devel or jump on the mail list if you'd prefer.

appreciate the work you guys are putting in to this.
Comment 11 Andrew Bartlett 2007-12-11 16:53:01 UTC
You are free to hang out on #samba-technical on irc.freenode.net, but working in this bugzilla is also very useful.  it does help me keep a list of things to work on. 

Please do separate the bugs, and provide details (such as the output of a failing provision script). 
Comment 12 Matthias Dieter Wallnöfer 2008-04-23 02:28:56 UTC
And how it works now?
Comment 13 Matthias Dieter Wallnöfer 2008-06-07 12:52:52 UTC
This is gonna be closed. Please reopen with a cause if the problem persists!