Bug 499 - Winbind panic when I tested libnss_winbind.so+pam_winbind.so
Winbind panic when I tested libnss_winbind.so+pam_winbind.so
Status: CLOSED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.0preX
All Linux
: P3 critical
: none
Assigned To: Gerald (Jerry) Carter
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-24 00:03 UTC by gary ng
Modified: 2005-11-14 09:24 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gary ng 2003-09-24 00:03:59 UTC
I am testing a setup of samba 3.0(beta 2) PDC using OpenLDAP 2.1.21 as the 
backend. The samba part seems to be functioning alright and even wbinfo -a 
completes normally as expected. But there seems to be some problem in the 
libnss_winbind.so : I setup the pam.d/login to use pam_winbind and 
nsswitch.conf to use libnss_winbind. 
 
When I tried to login with the form of "login Domain\\user", pam_winbind 
completes as expected but libnss_winbind caused the winbindd panic. The panic 
code is as below : 
 
[2003/09/24 14:43:52, 0] lib/fault.c:fault_report(36) 
  =============================================================== 
[2003/09/24 14:43:52, 0] lib/fault.c:fault_report(37) 
  INTERNAL ERROR: Signal 11 in pid 1280 (3.0.0beta2-0.nobse.1 for Debian) 
  Please read the appendix Bugs of the Samba HOWTO collection 
[2003/09/24 14:43:52, 0] lib/fault.c:fault_report(39) 
  =============================================================== 
[2003/09/24 14:43:52, 0] lib/util.c:smb_panic(1452) 
  smb_panic(): calling panic action [/usr/share/samba/panic-action 1280] 
[2003/09/24 14:43:52, 0] lib/util.c:smb_panic(1460) 
  smb_panic(): action returned status 0 
[2003/09/24 14:43:52, 0] lib/util.c:smb_panic(1462) 
  PANIC: internal error 
[2003/09/24 14:43:52, 0] lib/util.c:smb_panic(1469) 
  BACKTRACE: 12 stack frames: 
   #0 /usr/sbin/winbindd(smb_panic+0x16b) [0x80abd43] 
   #1 /usr/sbin/winbindd [0x809cbb2] 
   #2 /usr/sbin/winbindd [0x809cc05] 
   #3 /lib/libc.so.6 [0x402276b8] 
   #4 /usr/sbin/winbindd(strequal+0x2d) [0x80a48cd] 
   #5 /usr/sbin/winbindd(winbindd_getpwnam+0xba) [0x806cf2a] 
   #6 /usr/sbin/winbindd(ber_scanf+0x69c) [0x806bb8c] 
   #7 /usr/sbin/winbindd(winbind_process_packet+0x20) [0x806be40] 
   #8 /usr/sbin/winbindd [0x806c692] 
   #9 /usr/sbin/winbindd(main+0x493) [0x806cbf3] 
   #10 /lib/libc.so.6(__libc_start_main+0xbb) [0x4021714f] 
   #11 /usr/sbin/winbindd(fsetxattr+0x31) [0x806b571] 
 
It seems to be caused by libnss_winbind as if I omit libnss_winbind in 
nsswitch.conf, the daemon doesn't panic.
Comment 1 Gerald (Jerry) Carter 2003-11-07 11:11:36 UTC
please retest against 3.0.1pre2 (due out later today)
since beta2 is pretty old at this point and I have 
a feeling this has been fixed.
Comment 2 Gerald (Jerry) Carter 2003-12-12 08:28:10 UTC
reseting target milestone.  3.0.1 has been frozen.  WIll have to 
re-evaluate these.
Comment 3 Gerald (Jerry) Carter 2004-03-18 10:07:48 UTC
closing.  No feedback in several months.
Assuming the segfault has been fixed.
Comment 4 Gerald (Jerry) Carter 2005-02-07 08:40:22 UTC
originally reported against 3.0.0beta2.  CLeaning out 
non-production release versions.
Comment 5 Gerald (Jerry) Carter 2005-08-24 10:15:27 UTC
sorry for the same, cleaning up the database to prevent unecessary reopens of bugs.
Comment 6 Gerald (Jerry) Carter 2005-11-14 09:24:10 UTC
database cleanup