Bug 4946 - Winbind Kerberos tickets get deleted when using multiple sessions
Winbind Kerberos tickets get deleted when using multiple sessions
Status: RESOLVED INVALID
Product: Samba 3.0
Classification: Unclassified
Component: winbind
3.0.25c
Other Linux
: P3 normal
: none
Assigned To: Guenther Deschner
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 08:53 UTC by Rick King
Modified: 2007-09-04 08:41 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rick King 2007-08-31 08:53:30 UTC
Winbind stores kerberos tickets keyed on UID. This means that when two ssh sessions are started to a machine by the same user, both sessions share the ticket cache. When one session logs out the ticket cache is deleted leaving the other session without tickets.

I tried patching source/nsswitch/winbind_pam.c to append a random number to the ticket cache file. However, the winbind ccache is keyed on username and therefore this is insufficient. I do not have sufficient C experience to perform the modifications necessary, however, I am perfectly happy to help in any other way. Testing, etc.
Comment 1 Guenther Deschner 2007-09-03 04:57:55 UTC
I cannot verify this with neither 3.0.25c nor with 3_2 svn. 

Can you describe a little more how to reproduce it (incl. your pam configuration, etc.) ?
Comment 2 Rick King 2007-09-04 08:41:00 UTC
Oh, I've just checked this again and cannot reproduce it myself either. I'm sure it was there in a previous version and I guess I must not have checked after upgrading. I'm really sorry for wasting your time on this!