Bug 4939 - Server Manager: "Synchronize Entire Domain" not implemented
Server Manager: "Synchronize Entire Domain" not implemented
Status: RESOLVED WORKSFORME
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
All All
: P3 enhancement
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-29 14:37 UTC by Matthias Dieter Wallnöfer
Modified: 2009-06-27 09:10 UTC (History)
0 users

See Also:


Attachments
NETLOGON pipe improvements (18.86 KB, patch)
2008-12-27 05:55 UTC, Matthias Dieter Wallnöfer
no flags Details
NETLOGON pipe improvements (7.07 KB, patch)
2009-01-03 08:04 UTC, Matthias Dieter Wallnöfer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-08-29 14:37:05 UTC
Under Computer
Comment 1 Matthias Dieter Wallnöfer 2007-09-04 15:33:43 UTC
Now, after analysing the cause of the problem: in fact it is the missing implementation in dcesrv_netr_LogonControl. We need to bring this up.
Comment 2 Matthias Dieter Wallnöfer 2008-12-27 05:55:23 UTC
Created attachment 3832 [details]
NETLOGON pipe improvements

This refactors the NETLOGON code related to this bug:

- Introduces a new "SYNCSTATE" enum required by the "DatabaseSync2" call (acc. to WSPP)
- Make "DatabaseSync" dependant from "DatabaseSync2" (acc. to WSPP)
- Let "DatabaseSync2" return NT_STATUS_NOT_IMPLEMENTED (I'm not sure if this is also true when a domain is running in mixed mode)
- Make "LogonControl" and "LogonControl2" dependant form "LogonControl2Ex" (acc. to WSPP)
- Let "LogonControl2Ex" return WERR_NOT_SUPPORTED for now
Comment 3 Matthias Dieter Wallnöfer 2009-01-03 08:04:13 UTC
Created attachment 3846 [details]
NETLOGON pipe improvements

Improved version of the patch:
- Removed autogenerated code in "gen_ndr" files (because can be updated easily through "make idl_full")
- Corrected the NETLOGON torture test suite
Comment 4 Matthias Dieter Wallnöfer 2009-06-18 03:47:54 UTC
Comment on attachment 3846 [details]
NETLOGON pipe improvements

Applied
Comment 5 Matthias Dieter Wallnöfer 2009-06-27 09:10:46 UTC
I think I'll close this since with the latest patch applied we've a good error message which tells that we don't support this.