Bug 4894 - wbinfo --domain=NAME --sequence does not return anything
wbinfo --domain=NAME --sequence does not return anything
Status: RESOLVED WONTFIX
Product: Samba 3.5
Classification: Unclassified
Component: Winbind
3.5.0pre1
Other Windows XP
: P3 normal
: ---
Assigned To: Jeremy Allison
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 20:59 UTC by Serge Pashenkov
Modified: 2010-05-27 04:16 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Pashenkov 2007-08-17 20:59:11 UTC
I have parent domain NETLANTEK.NET and child NETCHILD.NETLANTEK.NET. The parent has two domain controllers, one is called win3k-pdc.netlantek.net. and the other one is called ccpqdl320-srv1.netlantek.net. I am joined to the parent domain, NETLANTEK.NET.

x228:200> wbinfo --sequence
NETCHILD : 80998
ccpqdl320-srv1 : DISCONNECTED
BUILTIN : 1187402313
X228 : 1187402313
NETLANTEK : 441295

But:

x228:201> wbinfo --domain=NETLANTEK --sequence
x228:202> 

Returns nothing at all.

x228:202> wbinfo -D NETLANTEK
Name              : NETLANTEK
Alt_Name          : netlantek.net
SID               : S-1-5-21-1305906595-1791979575-428400569
Active Directory  : Yes
Native            : Yes
Primary           : Yes
Sequence          : 441295
Comment 1 Gerald (Jerry) Carter 2007-08-17 21:13:37 UTC
Tis is by design.  The --domain is for -u & -g only.
Comment 2 Jeremy Allison 2007-08-17 23:22:57 UTC
I took a quick look in the code for --domain, and it;s being propagated to the call in winbindd. If this is by design we need to document it I think, or fix it so it works as people expect (a 3.2 project IMHO).
Jeremy.
Comment 3 Gerald (Jerry) Carter 2007-08-18 11:07:33 UTC
It's all yours.
Comment 4 Karolin Seeger 2009-12-02 04:49:23 UTC
Jeremy, would you like to fix that for Samba 3.5?
Comment 5 Guenther Deschner 2010-05-27 04:16:44 UTC
This command (--sequence) has been deprecated, please use wbinfo --online-status to check status of your domains.