Bug 4893 - Some valgrind things
Some valgrind things
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
All All
: P3 normal
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 11:11 UTC by Matthias Dieter Wallnöfer
Modified: 2007-08-26 21:32 UTC (History)
0 users

See Also:


Attachments
Valgrind log (22.01 KB, application/octet-stream)
2007-08-17 11:12 UTC, Matthias Dieter Wallnöfer
no flags Details
Here a patch. The error was caused by info1 that is'nt talloced but rather static. (1.45 KB, patch)
2007-08-25 05:32 UTC, Matthias Dieter Wallnöfer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-08-17 11:11:20 UTC
When testing SAMBA I noticed some SAMBA problems in the valgrind log. There are few, maybe different things.  I attach the log so you can distinguish the messages.
Comment 1 Matthias Dieter Wallnöfer 2007-08-17 11:12:48 UTC
Created attachment 2869 [details]
Valgrind log
Comment 2 Andrew Bartlett 2007-08-21 00:59:19 UTC
There are two different bugs here:  some issue with password sets, and another in the CrackNames code.

The password set case looks very interesting.  It will be *very* slow, but can you  run at log level 100, under valgrind, and repeat?

(I presume you have compiled with --enable-developer). 

This should show up if there is an issue with a lacking null terminator.  

Comment 3 Matthias Dieter Wallnöfer 2007-08-22 14:24:01 UTC
I think, it's better if I give you more details how I got the bug. Here the reproduction steps for the "DsCrackName" issue, where the whole smbd crashes.
- Login to a domain joined workstation with the local system administrator account (the Microsoft Server Management Tools should be installed)
- Launch the ADUC console
- Ignore the warning, telling that domain accounts should be managed with a domain user
- Rightclick on the top of the tree and select "Connect to domain..."
- Type in the domainname in DNS form
- Then open the properties of one object (for example of the domain object)
- Click on the security tab
- If displayed, ignore the warning
- Click on the button "Add..."
- There should now be displayed a login dialog for the network password
- Then type in "Connect as:" Administrator and the password
Now the SAMBA daemon immediately crashes.
Comment 4 Matthias Dieter Wallnöfer 2007-08-25 05:32:35 UTC
Created attachment 2886 [details]
Here a patch. The error was caused by info1 that is'nt talloced but rather static.
Comment 5 Matthias Dieter Wallnöfer 2007-08-25 06:57:32 UTC
The password problem seems not to be reproducible anymore. I see also, that the related files were changed and the line numbers doesn't comply. So I propose after applying the patch to close the bug.
Comment 6 Andrew Bartlett 2007-08-26 21:32:57 UTC
I've applied your patch in -r 24697.  Very nice work!

Thanks!