Bug 4892 - ADUC: Group policies
ADUC: Group policies
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
All All
: P3 normal
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-17 10:50 UTC by Matthias Dieter Wallnöfer
Modified: 2007-09-02 21:52 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-08-17 10:50:17 UTC
When I click the button "Add" in the tab "Group Policy" in the properties dialog of a newly created OU the ADUC console crashes.
Comment 1 Matthias Dieter Wallnöfer 2007-08-27 15:56:09 UTC
You wrote on the mailing list that this bug has been fixed. But on my test environment the MMC crashes till now! Please review it.
Comment 2 Andrew Bartlett 2007-08-27 16:48:15 UTC
No such implication was intended.  I've not reviewed this yet. 
Comment 3 Matthias Dieter Wallnöfer 2007-09-02 08:58:48 UTC
Now I've found the reason: when you add an OU with the ADUC console, there isn't added the objectClass "top". The ADUC doesn't find it then and crashes. But when you add it manually (f.e. with ldbedit) the problem is solved.
I think it shouldn't be to hard to fix this (also for the alpha). I thought, the best way is to add to *all* new created objects the objectClass "top" by default. What do you think?
Comment 4 Andrew Bartlett 2007-09-02 19:21:03 UTC
I'm going to refactor the code to ensure the full objectClass hierarchy (including top) is always present.  This I can do in the objectclass module. 
Comment 5 Andrew Bartlett 2007-09-02 21:52:46 UTC
I think this is now fixed by -r 24914, can you confirm?