Bug 4884 - Can't join domain
Can't join domain
Status: RESOLVED DUPLICATE of bug 4885
Product: Samba 3.0
Classification: Unclassified
Component: Domain Control
3.0.25b
x86 Linux
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-15 03:47 UTC by Marcin Giedz
Modified: 2007-08-15 03:53 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Giedz 2007-08-15 03:47:04 UTC
Hello

My PDC works on 3.0.23d with the following settings in smb.conf file

ldap passwd sync = No
unix password sync = Yes
passwd program = /opt/samba-3.0.23d/bin/spasswd.pl -u %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n

so my users can change NTLM passwords as well as userPassword via spasswd.pl. In this case everything works OK. I can join any windows machine do domain either. But with such settings I Can't join any linux machines. I get Failed to find Unix account for sidomatest$ in log file.

A part from the whole log file is added below.

[2007/08/08 15:21:26, 3] smbd/sec_ctx.c:set_sec_ctx(241)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 1
[2007/08/08 15:21:26, 2] passdb/pdb_ldap.c:init_sam_from_ldap(541)
  init_sam_from_ldap: Entry found for user: sidomatest$
[2007/08/08 15:21:26, 4] lib/substitute.c:automount_server(407)
  Home server: zasoby
[2007/08/08 15:21:26, 0] passdb/pdb_get_set.c:pdb_get_group_sid(164)
  pdb_get_group_sid: Failed to find Unix account for sidomatest$
[2007/08/08 15:21:26, 4] lib/substitute.c:automount_server(407)
  Home server: zasoby

I assume this is the problem. Because when I remove "unix password sync" from smb.conf I can join my linux machine. 

The same situation is with 3.0.25b. 

Regards,
Marcin
Comment 1 Volker Lendecke 2007-08-15 03:53:17 UTC

*** This bug has been marked as a duplicate of 4885 ***