Bug 4868 - notify related (endless?) loop causes high load on server
notify related (endless?) loop causes high load on server
Status: RESOLVED FIXED
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.25b
x86 Windows XP
: P3 normal
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-08 05:13 UTC by Franz Sirl
Modified: 2007-08-10 10:45 UTC (History)
0 users

See Also:


Attachments
level 10 debug log /1 (69.69 KB, application/x-gzip)
2007-08-08 05:16 UTC, Franz Sirl
no flags Details
level 10 debug log /2 (69.67 KB, application/x-gzip)
2007-08-08 05:18 UTC, Franz Sirl
no flags Details
Patch (327 bytes, patch)
2007-08-10 09:03 UTC, Volker Lendecke
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Sirl 2007-08-08 05:13:49 UTC
After saving an edited file in TextPad to a samba share, TextPad was unresponsive. Checking on the server showed high load for one smbd (25-100% CPU). Killing this smbd allowed everything to continue normally. I made a level 10 debug log though.
Comment 1 Franz Sirl 2007-08-08 05:16:39 UTC
Created attachment 2857 [details]
level 10 debug log /1
Comment 2 Franz Sirl 2007-08-08 05:18:29 UTC
Created attachment 2858 [details]
level 10 debug log /2
Comment 3 Volker Lendecke 2007-08-10 09:03:38 UTC
Created attachment 2861 [details]
Patch

Can you try this patch? I think this should fix it.

Thanks a lot!

Volker
Comment 4 Franz Sirl 2007-08-10 10:19:40 UTC
Looks very good! I rebuilt from the SAMBA_3_0_25 branch and so far I couldn't reproduce it anymore with roughly the same setup (TextPad+Explorer+TortoiseSVN) that provoked the bug reliably before.

Thanks for the fix.
Actually I catched this one by accident while trying to track down the corruption bug with VC6. No hard data yet (well, according to tcpdump it doesn't happen on the wire), so no bugzilla entry yet.
Comment 5 Volker Lendecke 2007-08-10 10:45:37 UTC
closing -- thanks for the feedback