Bug 4865 - single user specification with encrypt passwords off
single user specification with encrypt passwords off
Status: NEEDINFO
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.9
x86 Windows XP
: P3 regression
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 08:15 UTC by abliss
Modified: 2011-03-06 09:16 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abliss 2007-08-07 08:15:28 UTC
running redhat es 5 with samba rpm version of samba-3.0.23c-2, it appears that the encrypt passwords = no option will no longer allow for single users to be specified for share access.  The box has has been configured to authenticate against an ldap server via authconfig....authentication for normal use (console, ssh) works great....I'm having some trouble with samba using single ldap 
users or local users....It's rather weird, shares in which access restrictions 
are based upon ldap groups are working fine, getent group shows local 
and ldap groups, however attempting to assign access to a share for 
either a single ldap user or a local user doesn't work, and produces the 
following error when trying to hit the share:
smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User myuser1 !

For local users, I've added local os accounts as well as 
accounts in the 
samba database with smbpasswd
Comment 1 Volker Lendecke 2011-03-06 09:16:59 UTC
This needs much more information: smb.conf and debug level 10 log of winbind.