Bug 4861 - DOS application hangs after some seconds from start - shared files in DOS
DOS application hangs after some seconds from start - shared files in DOS
Status: RESOLVED DUPLICATE of bug 5138
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.25b
x86 Windows XP
: P3 critical
: none
Assigned To: Samba Bugzilla Account
Samba QA Contact
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-07 04:22 UTC by Irek Piasecki
Modified: 2012-07-26 09:50 UTC (History)
1 user (show)

See Also:


Attachments
This machine hangs in dos app on samba shares (615 bytes, application/binary)
2007-08-07 04:23 UTC, Irek Piasecki
no flags Details
This is going well, even if another hangs (619 bytes, application/binary)
2007-08-07 04:24 UTC, Irek Piasecki
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Irek Piasecki 2007-08-07 04:22:48 UTC
Hi.

From some years we use samba+DOS application written in foxPro to manage our stock, finances and so on. In our einveroment we use: centos4 update 5 and samba with him: samba-3.0.10-1.4E.12.2 This configuraton works great for our purpose.

I decided from some reasions to upgrade samba to version 3.0.25b and we felt in hang issue.

On client side there are XP professional. So one machine starts this DOS application. It's ip is 192.168.1.105 - then dbf tables are open, records are added and this machine works happy.

Then i start this dos apps on another machine with IP address 192.168.1.111. For some seconds, maybe few minutes this dos application just HANGS. We can't do no more, must we kill this dos apps. This dos application works still well on machine 192.168.1.105, even if 192.168.1.111 hangs (entering in endless loop ?? )

So i atached logs with debugl level=10, logs for 192.168.1.105 and 192.168.1.111

I attached also smb.conf and smbstatus.log (which machine has what files open) etc.

Please, have in mind: in samba 3.0.10-1.4E.12.2 this NEVER happen.

This happen (HANGS) also in: Centos5 and samba 3.0.23c-2.el5.2.0.2

So what causes this ??
Comment 1 Irek Piasecki 2007-08-07 04:23:58 UTC
Created attachment 2855 [details]
This machine hangs in dos app on samba shares
Comment 2 Irek Piasecki 2007-08-07 04:24:43 UTC
Created attachment 2856 [details]
This is going well, even if another hangs
Comment 3 Irek Piasecki 2007-08-07 04:50:59 UTC
Agh, i put all log files there: http://mbp.boleslawiec.pl/samba/

And:

1) http://www.mbp.boleslawiec.pl/samba/log.192.168.1.111.tgz  ... in this machine dos application hangs after some time, when operates on samba share
2) http://www.mbp.boleslawiec.pl/samba/log.192.168.1.105.tgz ... in this machine dos application works well even if machine 192.168.1.105 hangs
3) http://www.mbp.boleslawiec.pl/samba/log.laptop-ip.tgz == 192.168.1.105
4) http://www.mbp.boleslawiec.pl/samba/log.mbp-laptop.tgz == 192.168.1.111
5) http://www.mbp.boleslawiec.pl/samba/smbstatus2.log.tgz ... opened files by 192.168.1.111 and 192.168.1.105
6) http://www.mbp.boleslawiec.pl/samba/smb.conf smb.conf
Comment 4 Björn Jacke 2012-07-26 09:50:29 UTC
looks like a dup of bug 9030 and bug 5138. without having the logs any more here it looks like that. if you have dos clients make sure not to use intel cards. too many of them have broken checksum implementations that intel does not fix in firmware or in driver code.

*** This bug has been marked as a duplicate of bug 5138 ***