Bug 485 - Segmentation fault when trying to access mp3 directory.
Segmentation fault when trying to access mp3 directory.
Status: RESOLVED LATER
Product: Samba 3.0
Classification: Unclassified
Component: File Services
3.0.0preX
Other other
: P3 normal
: none
Assigned To: Samba Bugzilla Account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-22 03:42 UTC by Stefan Freyr Stefansson
Modified: 2005-02-07 08:40 UTC (History)
0 users

See Also:


Attachments
The output from "ls -l" in the directory that can't be shared (10.36 KB, text/plain)
2003-09-22 03:53 UTC, Stefan Freyr Stefansson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Freyr Stefansson 2003-09-22 03:42:36 UTC
I get a segmentation fault when I try to access my shared mp3 directory 
(shared from a linux box via Samba) from a Windows box. 
 
I've seen somebody else mention this so I'm pretty sure that this has to do 
with mp3 files:  
http://www.linuxquestions.org/questions/archive/1/2002/05/3/21380 
 
The weird thing is that if I create a new directory and share it I can access 
it just fine, then I tried to copy a few of my mp3 files into that directory 
and had no problem.  So the problem doesn't happen every time an mp3 directory 
is shared, there needs to be something else to it. 
 
Following is the mail I get if I try accessing the directory: 
 
From root@pandora-stfs Mon Sep 22 10:40:12 2003 
Envelope-to: root@pandora-stfs 
To: root@pandora-stfs 
Subject: Segfault in Samba 
From: root <root@pandora-stfs> 
Date: Mon, 22 Sep 2003 10:40:11 +0000 
 
The Samba 'panic action' script, /usr/share/samba/panic-action, 
was called for pid 1296 (). 
 
This means there was a problem with the program, such as a segfault. 
However, the executable could not be found for process 1296. 
It may have died unexpectedly, or you may not have permission to 
debug the process. 
 
 
Please let me know if I can be of more assistance. 
 
I'll be attaching a text file with the output of "ls -l" of the directory in 
question in case you guys might notice any issues with any characters or such. 
 
Kind regards, Stefan.
Comment 1 Stefan Freyr Stefansson 2003-09-22 03:53:22 UTC
Created attachment 156 [details]
The output from "ls -l" in the directory that can't be shared
Comment 2 Stefan Freyr Stefansson 2003-09-22 04:03:43 UTC
I tried for the fun of it to rename all the files and folders that contained 
Icelandic letters (such as &aacute;,&iacute;,&oacute;,&eth; or &thorn;) to 
pure ascii named files but that didn't work... I still got the seg fault. 
Comment 3 Andrew Bartlett 2003-11-08 13:40:09 UTC
There should at least be a backtrace in the logfiles.  Can you include it?

Andrew Bartlett
Comment 4 Gerald (Jerry) Carter 2003-12-07 23:09:53 UTC
closing.  No feedback in over a month.
Comment 5 Gerald (Jerry) Carter 2005-02-07 08:40:24 UTC
originally reported against 3.0.0beta2.  CLeaning out 
non-production release versions.