Bug 4847 - ADUC: Search tool needs 'anr' attribute for Ambigious Name Resolution
ADUC: Search tool needs 'anr' attribute for Ambigious Name Resolution
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
All All
: P3 normal
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 04:12 UTC by Matthias Dieter Wallnöfer
Modified: 2007-12-13 01:01 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-07-31 04:12:40 UTC
- Maybe you could also have a look to the search tool in ADUC. I think it
doesn't really work with SAMBA at this moment. I gave it a few times a try but
it never gave the correct results (every time an empty result). I was only able to get a result when I let the textfields empty. (from bug 4815)
Comment 1 Andrew Bartlett 2007-08-05 23:40:23 UTC
Perhaps we are trying some different queries - I added a new search for names starting with 'admin', and it seems to work fine. 

Can you give me some more exact details about what doesn't work?

Thanks,
Comment 2 Matthias Dieter Wallnöfer 2007-08-08 04:37:36 UTC
I remember I tried for example to type the username or contentname in the appropriate field. Then I tried also wildcards (*). I always got a blank result. But when I let all fields empty, I got the userlist. Maybe I do also something wrong.
At the moment I haven't my test environment disponible, so I have to wait a few days to test this better.
Comment 3 Matthias Dieter Wallnöfer 2007-08-20 06:08:55 UTC
For your request now a more detailled report:
- When I want to search something with the "name" field, I get always a blank result. I can only search if I leave it empty. But the "description" seems to work in the right manner.
- Also, on the second tab: if I click there on "Field" and in the pulldown menu on "user" (for example) I'm not able to get the fieldlist.
Comment 4 Andrew Bartlett 2007-08-22 23:57:45 UTC
The first problem is that Samba4 doesn't support ANR - ambigious name resolution.

In theory, this is a simple but probably a little painful query munger module I need to write.  Testing for the exact details will be key. 

I'm still unsure about the second problem - I've reproduced the issue, just need to figure out what ADUC is asking for, in terms of LDAP queries.  

I sure wish I could just ask Luke Howard about these things...
Comment 5 Matthias Dieter Wallnöfer 2007-08-25 07:13:22 UTC
I think the same problem is also in the User Manager for Domains. There exists also a search dialog: User/New Local Group.../Add.../Find... When you then try to type in something you get an error message box.
Comment 6 Andrew Bartlett 2007-12-12 21:59:08 UTC
No, problems with User manager are actually quite separate, as they use RPCs only, not LDAP. 

I've fixed Samba4 to support ANR, so this find dialog seems to work now. 

Could you file the 'field list' problem in another bug, so i can mark this one closed?
Comment 7 Andrew Bartlett 2007-12-13 01:01:57 UTC
There is now a shiny new, tested, anr module in the tree.  Reprovision or edit your modules list to use it.