Bug 4842 - User Manager: Policies menu
User Manager: Policies menu
Status: RESOLVED FIXED
Product: Samba 4.0
Classification: Unclassified
Component: Other
unspecified
All All
: P3 enhancement
: ---
Assigned To: Andrew Bartlett
Andrew Bartlett
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 04:00 UTC by Matthias Dieter Wallnöfer
Modified: 2008-10-20 06:50 UTC (History)
1 user (show)

See Also:


Attachments
A patch to lsa.idl (994 bytes, patch)
2008-03-18 10:21 UTC, Matthias Dieter Wallnöfer
no flags Details
LSA Patch for User Manager (21.82 KB, patch)
2008-09-27 18:42 UTC, Matthias Dieter Wallnöfer
no flags Details
LSA Patch for User Manager (21.34 KB, patch)
2008-09-30 05:04 UTC, Matthias Dieter Wallnöfer
no flags Details
LSA Patch for User Manager (21.35 KB, patch)
2008-09-30 05:09 UTC, Matthias Dieter Wallnöfer
no flags Details
LSA Patch for User Manager (21.48 KB, patch)
2008-10-04 17:36 UTC, Matthias Dieter Wallnöfer
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Dieter Wallnöfer 2007-07-31 04:00:43 UTC
The options in the "Policies" menu (Domain trust...) aren't implemented properly (Reference of bug 4815).
Comment 1 Andrew Bartlett 2007-08-01 20:31:17 UTC
In -r 24118 I've fixed the display of the trusted domains.  I still need to look into the other issues, and test actually adding a trusted domain.
Comment 2 Matthias Dieter Wallnöfer 2007-08-17 11:46:38 UTC
In a more recent SVN the "Trust Relationships" option seems to not work again (RPC error).
Comment 3 Matthias Dieter Wallnöfer 2007-08-18 05:05:29 UTC
In relation to the above: when I click first on "Policies/User rights..." I get an RPC error. Then, when I reselect "Policies/Trust Relationships..." the same RPC error is displayed.
Comment 4 Matthias Dieter Wallnöfer 2007-09-03 17:25:51 UTC
I've now analyzed a bit more the cause of the problems. In fact there are caused because some missing implementations in the LSA pipe.
- "User Rights" doesn't work, because the call "dcesrv_lsa_GetSystemAccessAccount" isn't filled in.
- "Audit" doesn't work, because there are missing options in "dcesrv_lsa_QueryInfoPolicy2". There doesn't exist only the three cases. We need to bring them all up.
Comment 5 Matthias Dieter Wallnöfer 2008-03-18 10:21:44 UTC
Created attachment 3190 [details]
A patch to lsa.idl

This should now make the lsa api for QueryInformationPolicy2 compatible with Microsoft WSPP docs (http://msdn2.microsoft.com/en-us/library/cc234321.aspx).
Comment 6 Andrew Bartlett 2008-03-18 17:36:02 UTC
Can you please extend the RPC-LSA test to walk over these options, and prove that (at the very least) the marshaling is correct?

Thanks,
Comment 7 Matthias Dieter Wallnöfer 2008-03-25 17:42:07 UTC
I'll try to do it.
By the way, shouldn't be syncronize the IDL's from SAMBA 3.2 with the ones from SAMBA 4? E.g. the SAMBA 4 lsa.idl seems older than the SAMBA 3.2 one.
Comment 8 Matthias Dieter Wallnöfer 2008-09-27 18:42:22 UTC
Created attachment 3642 [details]
LSA Patch for User Manager

New (major) patch
=================
- Enhances the "lsa.idl" file in the sense that it adds more values to "PolicyInformation" to improve the "lsa_QueryInfoPolicy*" calls.
- Adds a minimal implementation for "AuditEvents" (also lsa_QueryInfoPolicy* calls) to enable the "Audit" option in the "User Manager for Domains" (at least readable).
- Adds to the "lsa.idl" file the system access mode flags needed for the calls "lsa_*SystemAccessAccount".
- Fill in the "lsa_GetSystemAccessAccount" for enabling the "User Rights" option in the "User Manager for Domains" (at least readable).
- Merge the two similar torture tests of the "lsa_QueryInfoPolicy*" calls in one using "if"'s for a few separations.
- Add a torture test for "lsa_GetSystemAccessAccount".
- Some cosmetic-only changes (unifications) in output strings in the "LSA" torture test.

The work has been done using the Microsoft WSPP docs.
Comment 9 Matthias Dieter Wallnöfer 2008-09-30 05:04:29 UTC
Created attachment 3648 [details]
LSA Patch for User Manager

Updated version
Comment 10 Matthias Dieter Wallnöfer 2008-09-30 05:09:19 UTC
Created attachment 3649 [details]
LSA Patch for User Manager

Updated, because before I've created it in reverse.
Comment 11 Matthias Dieter Wallnöfer 2008-10-04 17:35:09 UTC
I add also Tridge to this bug because he has recently done some work on the LSA pipe.
Comment 12 Matthias Dieter Wallnöfer 2008-10-04 17:36:27 UTC
Created attachment 3657 [details]
LSA Patch for User Manager

Updated for use after Tridge's patches.
Comment 13 Matthias Dieter Wallnöfer 2008-10-20 06:50:02 UTC
Okay, I'm satisfied. Closing it as "FIXED".